Three WD MyBook Studio drives--constant recognition problems

I’m using an iMac with OS X 10.6.8.  I have three MyBook Studio external drives: 500GB, 1TB and 4TB.  I use one for all my photos, one for music and one for backup.

When I added the 4TB to my daisy chain, things worked well for awhile.  Then for unknown reasons the iMac failed to recognize one or more of the HDs.  First, I would take the problem drive offline, reboot the iMac, and that would fix it for a short period but the problem came back. 

After reading some recommendations on WD and elsewhere, I then bought a separate power strip for the drives only.  That worked for awhile…but the problem came back.

Then I connected two of the drives individually to the Mac, and have had no further problem with them.  However, the third is unrecognized (it’s still daisy chained to one of the other drives).  Re-configuring the connections among drives doesn’t help.

Before I plug the third drive into my last port, does anyone have other fix suggestions?

Some old WD drives, of the same model, cannot be daisy chained.  You can take a look to this link:

Here are the models I have:  1Q 1000n, 1Q 5000n, and 2Q 40000N.  I don’t know if any need firmware updates, etc.