There is no media in the current folder' accessing Network Shares on QNAP TS-110 NAS

A couple of days a go I upgraded to the new WDTV Live from the 2nd generation version so I could enjoy the slicker interface.

All my media is stored on my NAS : the QNAP TS-110. Unfortunately I was unable to access the media files on this device though the ‘Network Share’ option when selecting a ‘Content Source.’ Even though the folders on the NAS  containing the media files where showing, when I tried to open any of them I was prompted with the message '‘There is no media in the current folder’.

After several days of searching the internet and various forums for a resolution to this I gave up and called WD technical support. After an hour of trying various things, no joy.

But I persisted and eventually found a solution:

  • Login into your QNAP ADMINISTRATION page through your web browser.

  • Under ‘Access Right Management’, click ‘Share Folders’

  • Click on the ‘Share Folders’ tab if not already opened and you should see a list of folders on your NAS that are being shared under ‘Folder Name’

  • Under the heading ‘Action’ you will see various icons. Click on the one labeled ‘NFS’ to change the ‘NFS Access Control’

  • In the pop-up that appears change the drop-down for ‘Access Right’ to ‘No Limit’

Hope that helps someone as I struggled with it for days. If nothing else it will be a reference for me in case I forget how I did it.

Btw, I didn’t have to do any of this for my older WDTV Live so I am not sure what changed between models.

Edit: forgot to mention: after logging into your QNAP ADMINISTRATION page, you may also need to go to ‘Network Services’ and check the ‘Enable NFS Service’ box under ‘NFS Service’

So the WD 2nd gen didn’t do NFS. it only did Samba. Why didn’t you try the same thing on the SMP?

Hi, i’m not sure what SMP is. Could you give me a brief explanation in this context. Google only brought up ‘statutory maternity pay’ ! :slight_smile:

shopkeeper wrote:

Hi, i’m not sure what SMP is. Could you give me a brief explanation in this context. Google only brought up ‘statutory maternity pay’ ! :slight_smile:

'statutory maternity pay LOL

Streaming Media Player :wink:

For some reason I am again recieving the same '‘There is no media in the current folder’ but now though the folders on the NAS containing the media files are not showing and am prompted with the message as soon as try to select my NAS.

I’m not sure what happened between now and then. Maybe a automatic firmware update or my cousin who has been staying for a few days messed with some settings in the WDTV Live but I can’t figure out what.

TonyPh12345 do you happen to have a checklist I can follow. I know you posted in another thread about this same issue but i’m just not able to locate it anymore and stumbled across it accidentally before.

Btw still not heard a peep from WD Technical Support about this even though I was promised a email/telephone update about it.

May just have to cut my losse’s and return it to amazon if this frustration with the box continue.

The SMP is the short name of the WDTV we’re talking about.   SMP= WDTV Live Streaming Media Player, distinguishing it from the “WDTV Live HD”.

I had asked above why you were trying to use NFS instead of Samba.   

You had mentioned before that you were using an older WDTV on the QNAP, which did not do NFS.

Sorry, you’ll have to excuse my ignorance but what is Samba in the context of the WDTV Live please? I did a search on wiki and the forums here but i’m not so technically knowledgeable so not much the wiser.