Theme uploads ... seriously WD **bleep**

Hi everyone, as you can gather from the post message I am miffed at WD presently.

(i am in Australia and they aren’t allowing sale of the WD Play - apparently it has too many streaming services to be of use to the Australian market … apparently getting media from local storage is now a low priority. <<< rant over >>>)

To the issue. I have previously installed Darklight Theme using the browser log in. Easy. I am now wanting to try a different theme and Alaska looks nice. But it will not load. In IE it just takes forever and nothing happens, chrome and FF the waiting animation spins twice and it’s over really quickly but again nothing happens. 

(I see no reason why theme uploads can’t be done via USB! Surely this would make life easier for everyone. )

I have rebooted the WD several times, left the upload spinning for over an hour … nothing. 

I have extracted files and created new uncompressed zips and still nothing. 

Very frustrating so after countless readings of long threads and google searches it’s a plea for help and suggestions. 

My opinion of WD has taken a beating this past month or so as I am an enthusiast but to be denied the latest hardware and having to struggle to get the box looking good is discouraging. 

Thanks all. 


I should point out also that I have downloaded other themes to try and they too don’t work. 

random thought … dunno … is your firewall preventing you uploading a theme to the smp ??  (try turning it off maybe?)

1 Like

Great suggestion - will try this tonight. Curiously if I download a theme in the offical WD list it gets to 99% and then displays an error message. So it might be a firewall … don’t know… will test and let you know., 

Thanks for the input!

Hi,turning off the firewall made no difference unfortunately. 

I have since tried a reset from the option under Settings > System. resetting everything except the account passwords. 

Any other suggestions?


dunno if this makes any difference …

Before uploading another custom theme … change back to the Mochi (Default) theme before uploading

The smp can only hold ONE custom theme at a time … so if you’re currently running a custom theme and attempting to upload another … they *could* be butting heads with each other ?

it’s just a guess … probably wrong, but what the heck

some other reading with people with the same prob

1 Like


shaunl wrote:

Hi,turning off the firewall made no difference unfortunately. 


I have since tried a reset from the option under Settings > System. resetting everything except the account passwords. 


Any other suggestions?



If you are using the SMP and not the hub, go to settings/appearance/user interface themes and see what themes are listed. If using the SMP you should see the Mochi default theme and the last theme you have installed, if that is Alaska then select it and then select apply.

As suggested some themes can get mixed up.

Hope this helps.

1 Like

Hi all

Joey - Yes I had come across that thread before. You’re points about the Mochi are interesting. I have reset to Mochi and then tried to upload but still the same problem.

Ritaben - Thanks, I have installed Darklight before so no issues about an understanding of the process of installing themes, unfortunately for me it’s not working at the upload stage so Alaska is not there.

Now… to make matters weirder. If I do a reset of the device it starts back up not with the Mochi theme I have re-installed but with the Darklight! I have a feeling that Darklight is somehow stuck in cache (is this possible) and the system is not letting the Alaska upload overwrite Darklight. 

If I try to download one of the WD designed themes when the download gets to 99% it stops citing an error.

I’m getting frustrated at this so I thought I would do a full reset to factory defaults but no matter what I do Darklight comes up as the default theme. I don’t get it.

And I just found out that I cannot download new firmware - gets through the process and about 99% stops.

Baffled! Help! :slight_smile:

Got it … fixed. 

When I made the comment that I though Darklight was not able to be flushed from system i thought about it more - mind you I had looked for delete options on the WD and web log in but could find nothing. Then I realised the options button. Pressed it, deleted Darklight and hey presto - alasak uploaded. 

Thanks every one for help and input. Most appreciated 


Yay ! glad you got it working … :smiley:

Kudos to everyone who tried to help

1 Like

gladly done! Cheers