The WD MyCloud 2TB has encountered an error after updating to OS5.

Hello, I have a WD Mycloud 2TB that I haven’t used for a long time, and I need to use it to retrieve old data. I noticed that it no longer supports OS3, so I tried updating to OS5. However, almost a day after the update, I can’t access the hard drive and the blue LED keeps blinking. Please help me. Thank you.

Your device might be stuck indexing which can take a very long time, a day or longer, if you have a lot of user content on the My Cloud. If you search the correct subforum for your device (OS5 My Cloud) you will find a number of similar discussions on “blinking blue led”. It is possible on of those previous discussions may have additional suggestions or workarounds to try:

Are you able to get to the Dashboard? If yes, what is it showing? The image below is from my WDMYCLOUD 2nd generation.

No i can not connect to it.
I have tried two ways, which are entering through /wdmycloud and the IP address, but I can’t get in.

Until now it still blinking.

Probably won’t make any difference, but try Chrome rather than Bing.

“its a trap”

You probably are trapped until the dreaded “indexing” is complete.
I WOULD NOT REBOOT THE DEVICE WHILE INDEXING. If I recall; others have bricked the unit this way

If you ever do manage to get into the dashboard - - → Disable cloud services. That will stop indexing.

By some miracle: Can you SSH into the device? If so, someone smarter than me could tell you which process to kill (terminate) to stop indexing.

PS for future readers: Although WD does not say this, MyClouds will still function on OS/3. Just isolate the device from the internet (block at the router level) and use it as always. The only thing that no longer works are the internet functions.

PPS: Worst case scenario; if indexing ultimately bricks the unit; you probably can extract the HDD and recover the data using an external hookup and a Linux (EXT4) reader program.

1 Like