TCP Relay failed -- address for target domain not found

Just bought a MBL and am having real trouble getting wd2go to work.  It has worked once, but most of the time when I click on the drive in the wd2go screen (after login) I get the Apache Tomcat error above.

I found the instructions a little confusing, but I have mapped the MBL to and have set this as the static address in the My Book Live settings.  I have mapped ports 80 and 443 to the same address.  I know nothing about upnp, so I don’t know what to do about that, but it is on.  The remote access screen says “Port Forwarding Connection Established.”

Any help appreciated.

Check if you have the latest java version installed, you can also try another web browser.

Thanks, but that didn’t help.  I have implemented everything in the two files you linked, and Chrome gives the same error as IE.  And it isn’t java, because I’m not getting anywhere near the Java intro screen… except on the one time it worked.

Sorry to +1 my own post, but has no one else experienced this problem?  No ideas?

i encountered similar issue with error “HTTP Status 404 - TCP relay failed - address for target domain not found”, and log a case to WD, no reply yet.

I too have been receiving this error.  Java is updated and get the same result in IE and Chrome.  Looking forward to a solution.

Hi All, I am also getting the same error. So far no proper solution from WD. I am fighting with them daily to get this resolved. Hope I will have an solution ASAP. Will keep you posted.

i am another that is having the same issue.  i am curious on what the fix is going to be.

Looks like the WD device is using some overhead network encryption that does not read the TCP properly, it is really disturbing that there is not a solution for this as of now.

Has anyone gotten anywhere with WD about this.  i get no responce from them anymore about this issue.

I’ve got exactly the same problem just after I bought the 3T Cloud My Book Live.

My environment:

Ubuntu 12.04 + OpenJDK-7 + icedtea-7-plugin

On, by clicking View Shares, it only gives me: 

HTTP Status 404 - TCP relay failed - address for target domain not found

type  Status report

message  TCP relay failed - address for target domain not found

description  The requested resource (TCP relay failed - address for target domain not found) is not available.


Need help…

Best Regards


Bump as I have had this problem for a few months now.

Here is the responce i finally got from them a few days ago after opening the same many weeks ago.  i have not tried it, so use caution.  i have been using my device with FTP support have havent had any issues.

i havent done this cause they have not replied to me letting me know if this resets all the information on the drive also.

good luck to all

Dear XXXX,

Thank you for contacting Western Digital Customer Service and Support.  My name is [deleted for privacy].

We sincerely apologize for the inconvenience and the delay in this response, we will be more than glad to assist you with this issue. Please try to reset the unit, which is done by pressing the reset button, which is located on the back of the unit, right above the Ethernet port, for 4 seconds, and then releasing it. This procedure will restart it, which can take up to 3 minutes, and normally fixes some glitches that might be undergoing from bad firmware updates or other small errors.

If that does not solve the issue, please attempt to connect the unit directly to your computer by connecting the Ethernet cable from the drive, directly to the computer. This takes the Router, and thus the Network, out of the equation and will let us know if it’s a Drive issue or a Network issue. While trying this, make sure you try with a different Ethernet cable if possible, to rule out the possibility of a bad cable being the cause of this issue.

If you have any further questions, please reply to this email and we will be happy to assist you further.

Western Digital Service and Support    

Yes I had the same problem and this is how I resolved it.

Log in to my book via your browser.

Go to the network tab and set your static ip, subnet, gateway and dns

save those settings. then go to your remote access tab.

enable your remote access

connection options set to automatic

Save you settings.

Do not use any port forwarding in your router.

If you have set port forwarding in your router delete those setiings.

This should get you in bussiness

I tried your suggestion and now back to relay connection.  See files but can’t do anything.  I get the beachball spinning forever.  Then I went to router and enabled the UPnP and still no go.  Remote access is useless.  I don’t know what else to do.  Any other suggestions?  Thanks