Suddenly I can't download from iTunes Store (library stored on My Cloud)

I have my iTunes library stored on my WD My Cloud drive.  iTunes is set to use that location as the library, keep the library organized and copy new media files to the library.

I don’t use the My Cloud iTunes sharing or anything.  I mapped the WD to drive M and made a folder called iTunes and that’s where everything lives.

It’s been working good for the past couple of months that I’ve owned the My Cloud but just yesterday I discovered that I cannot download anything from the iTunes store.  I get an error that says “The required folder cannot be found.  Please check that the connection to the network is active and try again.”

The drive is accessible and my network connection is fine.  I am able to play existing music and movies that are located on the drive from within iTunes.

I have restarted iTunes many times and rebooted the PC.  I have tried organizing the library.  I even tried pointing the library location to the network share address instead of the mapped drive letter.  All the existing media is still there but I can’t download any new media.

Now, if I download a movie on my MacBook I can manually add it to the desktop library and it copies the file into the correct folder just fine.

My desktop is running Windows 8.1 x64

I have the latest iTunes version.  I think it just updated last week so perhaps that has something to do with it?

The best way to confirm if the update is related is by rolling back the application to the previous version and test if the issue disappears.

I tried going back to the previous version of iTunes and I’m still having the same problem.

I know as recently as 4/11 I was able to download a movie from the iTunes store with no problem at all.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country