Suddenly can't access My Cloud UI

I’ve had a My Cloud drive on my network for years. I have always accessed the control dashboard at cloudname.local/UI. Now, all of a sudden, I get a 403 Forbidden error. I didn’t do any firmware upgrades recently, so I’m not sure what happened here. Was there a forced upgrade that broke the web UI? I am on a Mac and am unable to connect via any WD tools as well. However, the drive still shows up fine in my Shared list and I can access all files.

Make sure to use http and not https.

Check your router to see what IP address the My Cloud has obtained. Then use that IP address in your web browser to see if you can access the My Cloud Dashboard.

Thanks. I get the same error, even when using just the IP address. I even tried dropping the “/UI” part of the path, just browsed to the IP address, but redirects to and the Forbidden error. So it looks like it’s getting to the My Cloud (otherwise, it wouldn’t redirect to that path), but something’s not working there.

Disable any browser addon’s. Disable any security/firewall software on the PC and test again.

Thanks. Good idea, but no luck there, either.