Successful enlarge ShareSpace 4TB to 8TB


#1

Have seen a few posts on this subject (was looking for guidance myself) so here’s how I did it - worked fine. Starting point was a 4x1TB ShareSpace in Raid 5.

  1. Checked firmware up-to-date (2.2.91)

  2. Backed everything up!

  3. Replaced each 1TB drive with a 2TB WD20EARS drive. Did this one at a time and allowed array to recover each time. As you’ll see, this might have been a waste of time, but this way worked…

  4. On replacing 4th drive, optimistically hoped that I would now have a 4x2TB Raid 5 array, but had read enough to know that this was indeed optimistic. Instead I had a 4x1TB Raid 5 array, and 4x1TB empty spaces.

  5.  Went to ‘Volumes and RAID Management’, ‘Manage RAID’ option in advanced menu and selected the same as I already had - that is, a Raid 5 array. When I hit ‘Submit’ the drive duly started rebuilding (power light flashing etc).

  6. A day or so later, it was finished, and my 2.68TB drive had become a 5.37TB drive. User details were remembered, though private shares had disappeared, along with all the data. Am now happily putting it all back.

Hope this might be useful for anyone attempting the same.


#2

Thank you very much for the initiative and the feedback, this information is likely to help many users.