Subtitles with .SUB extension doesn't work


#1

i made sure that name of the movie match with subtitle but .SUB extensions does not work.

i also updated firmware - still nothing.

Ideas, help, anyone? 

thanx.


#2

i notice that only      .SRT    titles are working… 

is it possible to update the firmware and resolve this matter?

we need    .SUB too…  :)


#3

Do you have the .IDX file too?  SUB files need the associated .IDX file for them to work.

My WD TV Live supports SUBs when the corresponding IDX is included.


#4

Lunar07 wrote:

Do you have the .IDX file too?  SUB files need the associated .IDX file for them to work.

Only if they are Vosubs. Officially the Live supports

srt <- text based, simple

sub <- text based, more fancy

Inofficially also

Vobsub = idx/sub <- bitmap based

The problem is that .sub is an extension to a number of subtitle formats so you may have to convert using Subtitle Workshop.


#5

ahha :slight_smile: learn something new everyday. 


#6

Where do you get the IDX-files and do you have to place the in the same folder with the movie file and the subtitles .str-file? Thanks in advance!


#7

You can convert text based srt to bitmap base idx/sub with AviAddXSubs or Subtitle Creator which workarounds the  LIVE’s pointless transparent outline on srt.


#8

Thank goodness I speak english since I have nothing but problems with subtitles with my WDTV Live.

Unfortunately I have the movie Ajami (arabic/hebrew) and it came with (ajami.subs.rar)  that includes the idx and sub when extracted. I located them the same directory as the ajami.avi movie that plays great.

When playing them WDTV says it has no subtitles. The closest I can come to understanding why it doesn’t work is that there are several “sub” formats and this one is not recognized even though it seems complete? Are there any utility programs that will tell you what format this is in and if compatible with WDTV Live?

It just took a while to figure out the the WDC forum doesn’t support Firefox and you need to use IE to log in :frowning:


#9

Note that external subs only work with Network Shares or local storage.  They don’t often work with Media Servers, unless the media server itself supports them…


#10

MAYZELEW wrote:

It just took a while to figure out the the WDC forum doesn’t support Firefox and you need to use IE to log in :frowning:

 

Actually I’m logging in with Firefox every day.


#11

I have a large number of DVD’s ripped to .mp4 with .idx/.sub subtitles. I have been using them for some time with my Seagate Theater+ media player. The file name of the .idx .sub and .mp4 files all match - it they don’t the Seagate player will not play them. I find that even though all the subtitles work with the Seagate player almost none of the subtitles work with the WD TV Live player. I do hope that WD addresses this problem soon.


#12

Welcome to the forums.

How are you playing these files?  If on a local drive, you shouldn’t have any issues.


#13

Thanks for the welcome. I am playing the files on a local usb hard drive. It is the same usb hard drive I use with the Seagate Theater+ player.

Today I dragged out my old WD player - WD TV - the one that did not connect to the network. All the subtitles played fine on the old WD player. All the subtitles play fine on the old WD player and the Seagate Theater+. The only player that does not play  the subtitles is the WD TV Live. Yes I have loaded the current firmware.

I suspect that when WD made all the improvements to the new unit they let some bugs slip in that were not present in the old unit. It is a real shame that they do not fix this problem. Perhaps WD is more interested in making the player work with the latest trendy codecs and containers rather than just making the basic functions work. I can certainly understand how the new stuff is more interesting than just making the basic stuff function correctly.


#14

Let me see what a WD tech has to say about this – in the meantime, can you post the full MediaInfo for a file that doesn’t work, along with the names of the sub files you are trying to play?


#15

Hi Mike,

This is indeed a strange one. There are a huge number of files that exhibit the problem. They all work with the old WD player and with the Seagate Theatre+. I tried to find one that would work on the new WD player but did not find one. I did not test them all but I did try about 20 of them.

The files were ripped to .mp4 and the subtitles .idx/.sub extracted using DVDFab 6. Each group of three files is in its own folder. Here is couple of samples of the file names.

Appoloosa 2008 1H 54M .idx

Appoloosa 2008 1H 54M .mp4

Appoloosa 2008 1H 54M .sub

Bad Lieutenant - New Orleans 2009 2H 1M.idx

Bad Lieutenant - New Orleans 2009 2H 1M.mp4

Bad Lieutenant - New Orleans 2009 2H 1M.sub

Here is a header from the .idx file

VobSub index file, v7 (do not modify this line!)

To repair desyncronization, you can insert gaps this way:

(it usually happens after vob id changes)

delay: [sign]hh:mm:ss:ms

Where:

[sign]: +, - (optional)

hh: hours (0 <= hh)

mm/ss: minutes/seconds (0 <= mm/ss <= 59)

ms: milliseconds (0 <= ms <= 999)

Note: You can’t position a sub before the previous with a negative value.

You can also modify timestamps or delete a few subs you don’t like.

Just make sure they stay in increasing order.

Settings

Original frame size

size: 720x480

Origin, relative to the upper-left corner, can be overloaded by aligment

org: 0, 0

Image scaling (hor,ver), origin is at the upper-left corner or at the alignment coord (x, y)

scale: 100%, 100%

Alpha blending

alpha: 100%

Smoothing for very blocky images (use OLD for no filtering)

smooth: OFF

In millisecs

fadein/out: 50, 50

Force subtitle placement relative to (org.x, org.y)

align: OFF at LEFT TOP

For correcting non-progressive desync. (in millisecs or hh:mm:ss:ms)

Note: Not effective in DirectVobSub, use "delay: … " instead.

time offset: 0

ON: displays only forced subtitles, OFF: shows everything

forced subs: OFF

The original palette of the DVD

palette: 000000, 828282, 828282, 828282, 828282, 828282, 828282, ffffff, 828282, bababa, 828282, 828282, 828282, 828282, 828282, 828282

Custom colors (transp idxs and the four colors)

custom colors: OFF, tridx: 0000, colors: 000000, 000000, 000000, 000000

Language index in use

langidx: 0

(Not detected)

id: --, index: 0

Decomment next line to activate alternative name in DirectVobSub / Windows Media Player 6.x

alt: (Not detected)

Vob/Cell ID: 6, 1 (PTS: 0)

timestamp: 00:00:43:424, filepos: 000000000

timestamp: 00:01:18:058, filepos: 000000800

timestamp: 00:01:21:595, filepos: 000001800

timestamp: 00:01:24:465, filepos: 000002000

timestamp: 00:01:26:967, filepos: 000002800

timestamp: 00:01:30:971, filepos: 000003800

timestamp: 00:01:36:510, filepos: 000004000

timestamp: 00:01:38:078, filepos: 000004800

timestamp: 00:01:53:060, filepos: 000005000

timestamp: 00:01:58:866, filepos: 000005800

The .mp4 files all play without problems on all the players. When I try to turn on the subtitles in the menu - a few choices for subtitles appear 1/3, 2/3 and so on. None of them display the subtitles. None of them display the language for the subtitle.

I do not think the problem is with the files I have created. I believe there is something wrong with the player. The only thing I could think of was to try and reinstall the firmware. I have been installing the firmware updates over the network (wired) so when I try to reinstall it just says - you have the current firmware. Is there a way to force a firmware update to the same version that is installed ?

I did read all the postings I could find on this problem and I did run across something that said .idx/.sub bitmap subtitles were not officially supported. That could be significant except for the fact that all the files work on the old player.

This is actually a big problem for us as my wife does not hear very well so we often have to turn on the subtitles.

thanks,

tom …


#16

 I did run across a beta firmware that indicated that one of the things they fixed was:

“Resolved sub+idx subtitle not working for supported subtitles”

I loaded the beta firmware and it fixed the subtitle problem - yippie.

Thank You,

tom …


#17

Good for you – you might want to mark this as solved with your own reply as the solution so that others might benefit.


#18

tomdoyle1948 wrote:

 

I loaded the beta firmware and it fixed the subtitle problem - yippie.

Apparently the new firmware is forgiving cause

(Not detected)

id: --, index: 0

usually hints at the tool ripping the Vobsub not doing a very good job or having to deal with a bad source.