Subtitles via different media servers


#1

OK here goes…

I have 3 WDHDTV live units all accessing a computer with vista 64bit and therefore windows media centre. Also they all access a verbatim 1GB NAS (1TB) with twonky media server (pre-installed).

The issues are:

  1. Connecting via media centre, I can play MKV files on both but the WMC gives me subtitles. The NAS does not.

  2. Connecting via media centre, I can play .VOB on both, but the WMC playa ALL .vob files WITHOUT any pause and also gives me subtitles. The NAS does neither

  3. connecting via network share gives me the same results as outlined in (1)/(2) above.

Questions:

(1) Why does WMC give me what network share/Twonky doesn’t

(2) I’d rather use a NAS so any recommendations to replace the verbatim (which was an experiment anyway)? Please assume budget of approx £1000 may pay a little more for something superfast and very very user friendly.

(3) Any fixes in the meantime for my problems?

Hopefully someone can help, thanks i adavance for your comments.

Many thanks.


#2

Check the version of Twonky Media Server. I have a WD Sharespace NAS and I have the same problem (subtitles not displayed in WDTV). I searched a bit and it seems that Twonky does NOT support streaming of external subtitles.

Contrary to you however, when I access the NAS as a network share everything is fine, but if I access it as a media share (ie using Twonky as a media server) external subtitles don’t work. If the subtitles are embedded into the mkv (using a special mkv tool) then they are streamed normally.

Did you try accessing the files stored on your NAS via a network share from your PC (for example using Media Player Classic as a viewer) to see if you get subtitles displayed? This way you will get a hint if it’s your NAS or your WDTV.


#3

Sioram, thanks for your reply.

My Twonky media server is version 4.4.17. as it was pre-installed I contacted the Twonky people to see how I could upgrade and they told me that they do not support pre-installed versions and I could try and use the version they supply for NAS’, however it is techinical and it is my problem if something goes wrong. This would have been ok if I had a back-up plan i.e. restore facility, but disks for the pre-installed version were not supplied. In any case surely in current times media servers would support subtitles?

I’ve taken your suggestion and found the network share via my computer does display subtitles and also plays the whole video without pausing between ‘.vob’ files. This is the case when I play the files using powerDVD and windows media player. It is strange  that the WDTV Live does not behave the same via network share. Is there a setting I need to do? I vagugly remember a post somewhere talking about mounting a NAS using an “xmount” comment from a local file atttached using the USB connection, to solve a similar problem but I can’t remember where I saw it.

I guess that conclusion is that it is not my NAS but must be something to do with my WDTV live as the connection to the NAS is identical from both my computer and my WDTV unit.

I’m exploring converting to mkv’s but would rather find a solution rather than convert all my files. Any further suggestions would be much appreciated.

Thanks


#4

First of all I think for the moment you should ignore the Twonky media server on your NAS as it appears that this may not support  the subtitles.

Therefore at the moment you should connect to your NAS via network shares. You never mentioned what sort of subtitles you are attempting play, if they are separate files and if they are named correctly etc. Perhaps you could give us more details of the files and subtitles you are attempting to play and how your media is organised on the NAS.


#5

Yes, richUK is right, do provide us please with some more details on files / formats etc.

Also, I agree that you should focus on getting the network shares to work as external subtitles don’t seem to be supported in the version you have, and surely trying to upgrade manually is a risky endeavour. I am not sure if  external subs  are even supported in latest versions. I searched the twonky forums but couldn’t get a definitive answer (See for example here:   http://www.twonkyforum.com/viewtopic.php?f=2&t=7102&p=26760&hilit=subtitles#p26760  )

Perhaps you are suffering from the network connections problems that have been reported? Did you try the latest firmware upgrade? Do other type of files play without interruption? 


#6

Currently they are dvd rips and there is no separate subtitle file that I can see. I assume it’s included in the one of the .vob files because it gets picked up by handbrake when its loaded, (it pick it  up as a bitmap file).

Speaking of handbrake, I converted the dvd rip to mkv with the bitmap subtitles included (it’s default was “burned in” - which I left alone). The resultant mkv file plays well via both network share and media server but the subtitle is now a permanent feature!!!, can’t switch them off via the options menu.

As a matter of interest, I also have m2ts files (bluray converted via clownbd) with seperate “.sup” subtitle files which play just fine via the twonky media server and I can switch the subtitles on/off. Geez!.

I now plan to try an emulate the m2ts strategy and convert the .vob files to mkv using handbrake and omit the subtitles. Then somehow extract the subtitles as a seperate file. do you have any suggestions on which software to use for the subtitle extraction as the one i’ve used so far extracts approx 10 files just for english and I only want one! OR am I going about it the wrong way?

As always, Thanks for your inputs


#7

Of course it’s a permanent feature, that’s why it’s “burned in”! Use MakeMKV instead to convert your DVDs to MKV which makes the subs selectable.


#8

I converted a dvd using only “default” as checked and this works well i.e. I can turn on/off the subs even via twonkymedia server. I’m happy that this is working, but now need to convert foreign dvd’s to mkv’s. The silver lining is that it all plays as one file and it takes up much less memory space.

I am have problems with converting M2TS files to mkv though (to reduce size). I use the following method:

(1) I have already converted some blurays to M2TS using clownbd in the past

(2) When I use hanbrake to convert m2TS it starts the encoding by saying “1 of 2  tasks 100%” and does not move onto the second tasks. It just stops. any ideas?

Thanks


#9

What I really find interesting is that you managed to have a video file and a separate subtitles file (.sup) and the twonkymedia streamed them well, when it can’t do the same with mkv file and external srt subs!!!


#10

@Soiram

Actually I did not try having the mkv and subtitles seperate beacause having set subs as “default” in handbrake, it worked. If it didn’t then that is what I would have tried and was in the process of looking for a subtiltle only extraction sotware from .vob files. What I could not do was play .vob files and switch on/off the subtitles.

I guess I could still try  having a seperate subtitle file with the .vob files but my other problem was that the .vob files would not play continuosly whereas the mkv give me both my requirements and consume less memory as a bonus.

Still not sure about mkv and .vob quality differences. I see posts where claims are made that there is no noticeably difference, but logically as there is more compression surely there must be a degradation of quality. I use Handbrake using the “high profile” setting and the video RF @20 which is set to something like approx 63% quality. I’m not experienced enough in the what this means but it appears to be a higher level of compression. Having said all that, I tried to compare both formats and can’t make up my mind if the diferences i’ve spotted are real or imagination!.


#11

Getting back to your original question. Do you have your DVD’s ripped into a VIDEO_TS folder. If they are then you can just play them by pressing play on the folder. You will get complete play-back of the main film plus subtitles. They have to be in the VIDEO_TS folder for this to work. (This works via network shares)


#12

@richuk,

Yes I do have them in a VIDEO_TS folder but they did not play continously either via network share or media server when accessing the NAS. As per my previous posts, it does play fine however ,(with subs) if I access the same movies on my computer. My connection speeds are fine as I can play M2TS files over both without any problems (including the seperate .sup files). It’s a strange one to me. which is why I was seeking an alternative format with the same quality levels. I think mkv might be it, but as I said before, I cannot determine if there are real quality differences or whether I’m just imagining them.