Subtitle control no longer displays in Option Menu

I’m unable to turn on Subtitles. The Subtitle options have disappeared from the Options Menu and the Subtitle button on the remote control does nothing. This problem just started recently; subtitle function has always worked perfectly. Firmware version is 1.02.17. I’ve tried doing a Factory Reset, etc., no change. Anyone have any ideas?

Hi, have you tested movies that have worked in the past? What kind of subtitles are you trying to use?

Hi lluna: Thanks for your response.
Yes, I’ve tried movies that worked in the past.
All of my subtitle files are in the same directory as the movie, have the same name as the movie, and end with .SRT
Subtitles were working fine since I got the unit about 2 years ago. The option to turn subtitles on and off, disappeared from the Options menu a few days ago. Subtitle button on the remote control no longer works either. Unit did have a firmware upgrade about a year ago, but again this problem just started a few days ago.