Subtitle-bug for south-slavic languages

Hi there, I own the 1TB Elements Play, upgraded the firmware to 1.10 (the last one on the update page), but I still have the same problem: subtitles are not represented properly. I use south-slavic subtitles (Bosnian, Croatian, Serbian). In settings, I tried both “Central European” and “Serbian”, but some letters are still represented with an underscore (_), mostly the “ž” and “š” letters. Tried to circumvent the problem by converting them to idx/sub format (bitmap-format) which represents them OK (after all, these subs are pictures) but the size is way to small (at the maximum size in settings still hardly readable). Please provide an firmware update, because this error affects at least 6 countries in the region.


what type of subtitles format are you using? Also did you verify if those subtitles are supported by the media player. See the user guide below:

Hi Nesvic, Thanks for the prompt reply. I am using the .srt format, I believe it is the most common format for divx-subtitles. The same subtitles are correctly shown on my Samsung DVD-Player (with integrated HDD). I have also looked in the manual - I didn’t find the list of supported subtitle-formats there (although I have seen .srt somewhere mentioned - maybe in the datasheet). In the manual, I could only find supported subtitles formats by this external MediaInfo freeware. Any other ideas?

Found the solution for the problem, thought I’d share it for the other ex-yu folks which bought the Elements Play. It is very simple - the subtitle files (.srt or .sub) have to be UNICODE, if they are ANSI, the “š” or “ž” characters are represented as “_”. So, how to encode it? Open the subtitle with Notepad, choose SAVE AS, as the new ENCODING (last drop-down in the save as menu) choose UNICODE (btw, UNICODE BIG ENDIAN works as well). Now I can enjoy at last my Elements Play, although after hours of trial-and-error. Couldn’t the folks at WD have written down somewhere that subs should be in UNICODE? After all, my 6 years old Samsung reads the ANSI without a problem…

Thanks for the solution.

Btw it seems that we have to deal with the problems ourselves (instead WD is doing this for us) :cry:

Did anyone try contacting WD technical support?  Whenever I have spoken to them they have been very helpful, even calling me back (in the UK) with an answer on one occasion.

If you don’t ask them they can’t help.

Not everything is in the manual.

I would expect at least one person from WD to read/answer this official WD forum but that’s not the case. That would save a lot of support calls.

Remember that this community was created for Users, such as yourself, to help one another, and to share your experiences and ideas with one another, some WD staff members read this forum, time to time, but , if you are looking for technical support from WD, you will need to contact them directly.

To Contact WD for Technical Support