SU on MyBookWorldEdition, White lights doesn't work anymore


#1

Another post, of the top of my head!

I seem to recall that when I first installed my MyBook, I could ssh login via terminal on my MackBook to the NAS. When logged in you could use su to perform root tasks like changing chmod codes and file ownership. 

Now (one NAS firmware and several OS X updates later) I try to change into root (su) and the NAS respond that su is an unrecognized command. Neither su, sudo nor root works. There are files on the disk that I would like to change owner/permission status for. But I can’t chmod or chown because I don’t have sufficient permission. I cannot become superuser anymore, so I cannot do anything about it!

Anyone have any suggestions or ideas  as to why su doesn’t work, and maby if it can be enabled again?

Best regards

// Gus


#2

What do you mean “neither root works” ?

root account should work always.

Is it just probably after firmware upgrades is does have ressetted to default paasword.

As for su or sudo… i recall having issues too on my book world, so im not using those commands. I just log on using root account when I need to do something with root access.


#3

I actually mean ‘neither root works’. The administrator profile is open for log-in. I have also assigned my user profile administrative rights, but I still cannot execute chmod or chown for some files/folder with the response: permission denied. If I was actually superuser/root, I would be able to change, remove, move or edit any file present on the system But since I still receive the permissions complaint, I am not truly a super/root user on the system even though I have assigned my profile administrative rights.

I have elaborated my approach somewhat and found even things I would find to be strange behavior. When trying other GUI SFTP transfer tools (MuCommander and Fugu), I can actually put files on the NAS using my log-in profile. If I do this, the files playback on the PS3 without complaints. The problem is that the files/folder uploaded into the Public directories become owned by my user, so I can stream the material onto any other media player in-house. But I cannot ‘chown’ to “all users” or ‘chmod’ because of missing permissions, neither can Idelete created files unless I use terminal to SSH in and rm files from my account.

While poking around in this mess, I also found some minor differences between Mac and PC. Everything uploaded from PC in-house gets stored under ‘u, g’ nobody,  jewab. But using SFTP tool, or the not working finder shortcut, files from my mac gets owned by guest, jewab. Again, no possibility of chown/chmod

Any thoughts?


#4

still not quite following…

Did you tried to log into ssh using default password: root / welc0me ?

Does it says password inccorect?


#5

I don’t blame you! Once again I got to worked up tp be able to formulate myself as a human being!

Of course you are right, I changed the root password to prevent unauthorized editing. I got to hung up on exercising my administrative rights as my own user profile in the form of SU or SUDO that I forgot to login as root with the modified password! I’ll try that later tonight.

Huge appology from me to you! And thank you for your help!!!

I guess I’ll have to work out the SU/SUDO part later on, but root will get me there for now!

Best regards

// Gus


#6

I believe that I sorted issues with ‘su’ and ‘sudo’ by re-installing those commands from optware and then executing them from /opt/bin.


#7

Thanx, I’ll look into that!

Well root acess work perfectly. However, it did not solve the problem with playback on my PS3, owner/permissions have nothing to do with the ability to playback!

// Gus