Stuck at 0% on update

WDTVLiveHub #2 of 2.

Against my better judgement, but lured in with the promise of Spotify, I upgraded my 2 Hubs.

First one went as it should.

Second downloaded and rebooted to upgrade, and will just sit > 15 mins with no change.

Since it was already not well, I went ahead and powered it off, it came back up and again attempted the upgrade, with the same result. Repeated this twice.  Did a reset, same result. 

Any suggestions?

I have 3 WDTVLive and 2 Live Hubs, which seem like awesome in theory, but seems like I have to do 30 mins of reading at every change.

Anyone else have an issue with the LiveHub taking 15 mins to boot, stuck on the “Loading…” screen?  If I hit home it goes to the menu, but the local hd doesnt show up.  If I do wait it out, it will EVENTUALLY come up and work.  I have duplicated this behavior on 3 Live Hubs now. 

RobPatton, maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support