Streaming Buffer?

Is there a streaming buffer?  I just purchased the WD TV.  I have it all set up.  I started watching a video off my networked drive and it acts like a bad connection streaming.  It works for a short time then the video slows down and i lose audio.  After a few seconds it starts back up again.  I am connected via wireless but I have the unit 3’ away from the router.  Checking the signal it shows full bars. 

  1. Is there a setting on WD TV to increase the buffer size?

  2. Can it be increased in another way?  Adding a flash drive?

  3. Is it a router setting?  QOS for video?

it’s probably some setting in the router

you’re probably not connecting on dual band N

maybe it defaulted to g or something like that

I have mine hardwired to a network drive through one or two switches, and it plays any video, even very high bitrate ones flawlessly.  I’d say it’s because you wifi connection stinks possibly due to interferance.  One thing to try is to move the channel your router is using.  But if you want reliable data transfer, wire is the only way to go. 

Thanks.  Apparently have a bad signal or need a setting change on the router.  I connected wired and it works fine.

The problem still exists after wiring directly.  At first it worked fine for about 15 minutes then it started to slow down the video and lose the audio.  I checking streaming video on my router and QOS is set.  I even added priority to the LAN port.  Any other suggestions?

RichardJoline wrote:

The problem still exists after wiring directly.  At first it worked fine for about 15 minutes then it started to slow down the video and lose the audio.  I checking streaming video on my router and QOS is set.  I even added priority to the LAN port.  Any other suggestions?

If you’re streaming from a device on the LAN, QOS on the router won’t do anything, and you likely don’t need it.  QOS on routers works only for traffic going between WAN and LAN, and the LAN ports on a router are simply connected to a switch.  Since I assume the network connection between the network drive and WD is 100Mb or 1Gb, that’s plenty of bandwidth, even with a reasonable amount of other unrelated traffic.

What kind of network drive is it?  Is it a dedicated NAS or a PC with a shared drive?  When you’re playing the video, is the drive activity light on constantly like it’s not able to keep up?  If it’s a Windows PC, is the drive heavily fragmented?  I have a Dlink DNS-323 and a 100Mb network and my TV Live does great on it.  

What router are you using?

FYI where streaming is involved - always use wired where possible. Wireless introduces lots of potential for issues and is always used only where you have to…

I suspect there is an issue with how the switch in your router works here.

Is the source of the files wired in as well?

Here is my set up.

Lenovo Thinkpad

Windows 7 Pro 64-bit

Hard Drive Samsung SSD 1 Tb

SSD is 1 month old and has 650 Gb free space

Netgear N600 Wireless Dual Band Router WNDR3400v3

Videos are on:

USB Wired 3Tb WD My Book HD

USB Wired 4Tb WD My Book HD

WD My TV is network wired to router

Music streams fine

MP4 seems to be fine

VUDU plays fine

Looks like my only problem is ISO/VOB files.  Those are the ones breaking up

I see the WD is connected to the router via ethernet now.

Is the computer connected by ethernet as well?

In my experience - wireless in the signal path causes lots of problems with media streaming. ISOs will be more susceptible than a lot of other files as ISOs tend to be higher bitrate. 

WD My TV is wired to the router.  I have turned off wireless.  Yes, the laptop is also wired with wireless turned off.

RichardJoline wrote:

WD My TV is wired to the router.  I have turned off wireless.  Yes, the laptop is also wired with wireless turned off.

How large is the file, and how many minutes is it?  I’m just trying to get an idea of the bitrate.  Assuming your network is ok, I’m leaning towards the laptop.  When playing the video, does the laptop hard drive light become nearly solid “on”, especially when the WD starts stuttering?  If so, your laptop might not be keeping up.  How fragmented is the drive this file is located on?

jrmymllr wrote: I’m just trying to get an idea of the bitrate.

The best way to get a precise idea of the “bitrate” (plus lots of other stuff) is to use Medioinfo to examine the media file

Any resolution, Richard? I have a similar problem. I have recently installed and copied all of my media files to a 6TB WD MyCloud cabled directly to a 10/100/1G Ethernet switch on my LAN. I have an older WD TV Live downstairs directly wired into the same Ethernet switch that streams VOB’s just fine from the MyCloud NAS. I added a new WD TV Personal Media Player (the WD TV Live with no Netflix), have no problem with pictures or audio but see the same “juddering” you are discussing when playing VOB’s. It was significantly worse when I started with WiFi feeding the WD TV. When I installed a 500 mbps Netgear “Ethernet over Powerline” adapter it improved significantly but still hits spots where it runs glitchy. Again, as you described, the picture gets jerky, kind of like its on a slow fast forward, and audio goes away. It may correct itself or, if I hit Pause, then Play, it will usually return to normal. I have noticed that the glitching can repeat at specific points in a video, i.e., see it glitch, rewind back a minute, start it normal again and it will glitch at the same spot. I also took my old WD TV Live from downstairs, wired it in upstairs, and saw the same problems.

I am going to try 50 feet of hard cable tonight just as a test. I am thinking this is a throttle up/throttle down bandwidth problem that the buffer of the WD TV just can’t support. Is this a buffering problem and is there any true buffer in the WD TV? I am thinking I could solve the whole problem by just hanging a big drive off of the WD TV and allowing the NAS to periodically transfer everything over the network to it but that kind of defeats the whole Network Share concept.

If I find an answer I will let you know. If you find anything please pass it along.

No, i have not received a resolution.  Mine is all hardwired and the external hard drives containing the ISO/VOB files do not play.  But have found that if they are on the root drive they play fine.  So I know it will play the ISO/VOB files, just not if it is not on the root drive. 

I have solved it on my end. It is simply a matter of consistent data speed, I believe. I also ran a cable 75 feet from downstairs to upstairs and everything started working solid. However, one thing to watch is that the WD TV will automatically switch back to any WiFi it can as soon as cable connectivity is lost. I have a My Cloud NAS hanging on an 8-port network switch that also has a WD TV Live downstairs and now a WD TV Live without the Netflix (Personal Media?) Both media players are set up for network share and everything is working fine.

I have a very similar setup, including powerline adapters to improve connectivity, and I also experience hangs that require either a rewind and play or a restart of the whole file and a resume to the point of failure.  I’m also using a myCloud hardwired to my router as the source so it’s hard to be clear where the problem lies - in the wiring solution, the myCloud or the WDTV.

I also have a major problem with audio on the WDTV in that I sometimes have to restart it 3 or 4 times before the audio will work through my home cinema (Sony) amp via HDMI.  I don’t see that this can be a hardware issue with the amp or HDMI cable as, if it worked on Wednesday, it should work on Thursday if nothing else has changed and it usually does work after a few restarts of the WDTV.

It’s a shame as I really like the interface of the WDTV but I’m getting to the point where I feel like looking to purchase something more reliable and consistent.

Thank you Richard for giving solution for this topic Streaming Buffer. This helped me and I seen many other messages who has been also got help from your reply, Keep you good work. Please let me know if this will also work with new WD TV Media Player Firmware Version 1.02.17