Strange WD Elements behaviour

Good morning/afternoon.
I have two 4TB WD Elements disks, the faulty one being an SE.
It is formatted in NTFS, which let me work perfectly on my Apple Macs and on my Windows laptop.
I was watching a video on the Windows laptop and the image frozen. No way I could find a solution and disconnected the disk after turning off the laptop. After this, I could not mount the disk on the Windows, neither on the Macs.

When I run the “solving problems” on Windows, it says the disk has no controller (don’t know what that is) and there is no downloadable controller Windows could “offer” me.
On the “Disk Utility” for Macs, the disk is recognizable as WD ELEMENTS SE 25FF MEDIA, with 4TB, but… nothing more.
When I click the “First Aid” button (which detects and repair errors), the disk is considered OK, with no repairs needed!!! But the system doesn’t let me mount it, only format it, which would clean ALL the information/files I have on it.
I don’t know what else to do, so I expect you could give me some tips on how to circumvent the problem.

UPDATE: To add for my previous information, I bought an app called “Disk Drill” and had an invaluable costumer help from the board.
Following their instructions - and after 25 hours - I made a dmg disk image on another WD My Passport 5TB disk.
But, unfortunately, I couldn’t retrieve my files from there, too.

Having the disk dmg image backed up, I tried to reformat the faulty 4TB disk. I couldn’t.

I contacted WD customer’s help and I’m being helped but, until now, don’t solve my problem

Any invaluable help would be much, much appreciated.

Thanks in advance.

Best regards

Arlindo Silva - Portugal

PS: If needed, I can upload some images showing Disk Utility’s messages…

Hi @Prog4ever,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Thanks for your reply.
And yes, I was helped by one member of the staff (Mr. Kevin S.), but this was a very generic help, one of the tips was asking the community, which I’m doing now…

Open your image file in DMDE and show us the Partitions tab:

You can also open the image file in a hex editor, eg HxD (freeware):

Can you retrieve a SMART report from your problem drive?

I’ve already sent the disk to the WD services. I’m waiting for a refund…

Thanks for all your help, guys! Very appreciated

fzabkar via WD Community <> escreveu no dia quinta, 31/08/2023 à(s) 20:06: