Strange behavior from WD Enterprise 4TB drives

I am not sure that i’ve choosen the right place to post an issue, but here it is. I have HP Proliant Microserver Gen8 with Adaptec 6805E Raid Controller. I had 4x 4TB WD Enterprise drives inserted and suddenly i noticed that Raid0 gives me 60 Mb/s write speed on these drives. I took 1 drive out and inserted it into usual PC (good one), checked speed - 15mb/s write - What ?!?!? Took all 4 drives out and they all show same speed. I tried formatting - no change. All tests show that drives’s health is perfect. Drives were new (only 8 months of work in a really low load). Well, i created RMA, WD gave me new drives (really good from them), this time its new WD Gold, i was happy. I inserted these drives into PC to check speed - woah! 210 write on HDD is insane - ok. Then i inserted them into my Microserver and what do you think - 60-80 write speed in any raid mode. I took out 1 WD Gold inserted it back to PC and - what?!?!?!? - 15 mb/s again!
I totally dont understand what is happening, any ideas?

Thank you.

Hi there, do you have other internal drives that can be used to test it on the server? Also, can you check the drives’ speed on a different PC as well to see if you get the same result?

Hello! Thank you for reply. I’ve tried same operation with pretty old
Hitachi drive - same result: before inserting into Microserver with 6805E i
tested speed on another Microserver without any raid controllers whcih
showed me 130 write speed, after that i inserted it into my Microserver
with 6805E and speed dropped to 60 mb/s (tested on different PCs). So the
question is - how to recover? Fast format didnt help. I started super long
format on 4TB drive which should finish on Monday and i will see if it

4days format didnt help. Read speed is 210 is it should be, write speed - 15 mb/s. Guys i really need help, loosing 4x4Tb Golds is not a joke :frowning: