Strange beeping sound


#1

Hi all,

My WD My cloud started acting up yesterday. It had this red indicator light on it. I tried mounting it on USB but it just won't help. I don't feel/ hear it running except for the first 30 seconds that I can hear this beeping/ buzzing sound.

https://mega.co.nz/#!do9wlBTK!-r1xvM8qXOAAFWFl9KCrUeE8CUgAn14r0uZiFxalkOo

Anybody here that can point me to the right direction on how to fix or recover my files? Thanks.


#2

Hi, welcome to the WD Community.

Im sorry to hear that you are unable to access the drive. Have you tried resetting the unit but pressing the reset button in the back?


#3

Hi thank you for your question. Yes i tried resetting the device, but I’m still getting the red indicator light. As I’ve said I already opened it up and even connecting it via an external enclosure did not work for me.

I’m really curious what the beeping sound that I was hearing. Does it mean that it has mechanical failure? If so what kind? And how do I fix or recover my data? Thank you again.


#4

Hi, I missed the part where you said that you took it out of the enclosure, my bad. :flushed:

After re-hearing the sound with better headphones it does seem to have physical damage. WD have a few  Data Recovery patners and some of them can give you a free quote.


#5

A post was split to a new topic: Beeping My Cloud