Stopping the indexing for good (known methods won't work)

Hey there,

I have the device running 2.31.195 firmware (ssh access enabled). It drives me nuts, indexing files and not going to sleep. I just want it to work when I access it…

I wanted to follow the guidance from (same as mentioned on this forum a couple of times) to kill the indexing services, but these two instructions:

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

always result in:

-sh: update-rc.d: not found

Therefore, nothing really happens and the bugger still spins every now and then. Way too often. What can I do to kill these processes permanently, please?

I would like to add that whatever I could have done via the web interface I did (e.g. stop the iTunes server, Cloud and DLNA).

Please help, thank you. :slight_smile:

Perhaps this has been finally resolved for this firmware version but I can’t find it, in which case… I’d appreciate a gentle nod on where to go. Thanks.


What happens if you run these two commands via SSH? Do you get an error message?

/etc/init.d/wdmcserverd stop

/etc/init.d/wdphotodbmergerd stop

How long have you owned your WD My Cloud? How do you back up to your My Cloud and how often? Do you ever see the front LED doing a slow pulse? You can find more information here along with the User Manual.

Have you opened Twonky and looked at the Settings there? See image below. Click on, tap or activate image to enlarge it.

Nope, but:

/etc/init.d/wdmcserverd stop
Stopping wdmcserver
sh: you need to specify whom to kill

And with the second one:

/etc/init.d/wdphotodbmergerd stop
Stopping wdphotodbmerger
sh: you need to specify whom to kill

Thanks for all the help. :slight_smile:

I’ve had it for two years or so and it’s been driving me crazy since then. :slight_smile:

DNLA is stopped so I can’t access Twonky at myip:9000. I don’t think it runs.

Have you already looked at this?

Yes, I have.