STILL no Media Library on WD TV Live

I’m experiencing what looks like a serious problem with generating the media library on WD TV Live. I bought it last week and updated the firmware to the current version (as of September 30). I have my media files on My Book Live Duo 6 TB connected to my home network. In WD Tv Live I added a few folders with mp3 and video files to the media library, as described in the manual. The LED on the front started blinking and kept at it for almost 24 hours. Looking at the contents of MBLD, I could see the media database being built.

After the blinking stopped, the result was:

  • The home screen still shows “0 new items” for all the media categories, the media library seems empty

  • Only one folder on MBDL contains the media database. This happens to be the folder with mp3 files. WD TV did create its .wd_tv hidden folders in the other locations I added, but in other locations these folders are empty.

  • The .wd_tv folder for the mp3 location still contains a lock file (wdtv.cas2_lock_file_check_0090a9c4804e) and an sqlite journal file (wdtv.cas2-journal). This is HIGHLY suspicious, since the journal file may only exist if database creation failed at some point and did not finish cleanly.

Next, I removed all the folders I had previously added, cleared the library, restarted WD TV Live, and tried adding only a single small folder for testing. I first tried it with a folder contaning a few avi and mp4 files, then with a folder ontaining only a single mp3 album. In both cases the results were the same: nothing in the media library, and sqlite journal files left over after what seems like an aborted compilation. No error messages from WD TV Live at all, no indication that something does isn’t working.

The sqlite databases themselves do not appear damaged in any way and seem populated with the correct data. When opened with an sqlite-aware application, each of the databases WED TV created during my attempts contains the expected file listings. But the left-over journal files suggest the database creation process crashes or halts at some point, without indicating any error to the outside.

Is there anything I can try before I throw the borken thing out the window and never buy anything from WD again?

Don’t go throughing it out the winwdow its likely not the device thats the issue.

What router do you have?

How are you sharing your media?

I have a Fritz! Box WLAN 7270 a fairly decent router, with a Fritz WiFi repeater right next to the WD media player.

Sharing is from the Public folder on a WD My Book Live Duo.

(One other thing I noticed, with the factory firmware, WD TV Live offered MBLD’s DLNA server in the content source menu. After updating to the current version, WD TV no longer communicates with the DLNA server on that disk.)

The device itself is okay, but WD’s software is just atrocious. Even if I get the media library to work, it still won’t play avi files over WiFi, a problem that I see was first reported a year ago, and still has not been fixed. (Plays AVIs fine from a pendrive plugged into the player, but the whole point of buying WD TV LIve was to not have to copy files to a pendrive every time my wife weants to watch a movie.)

Also, when the media library already exists, adding a new folder to it has no effect. The deviuce accepts the new folder but never scans it (turn ML off and back on, power cycle the device, nothing helps). Even if I get the LED to start blinking again for a while, the newly added folder is never picked up. It would seem that in order to add a single movie or mp3 album to the library, you have to clear the library and start over.  Given that WD Tv Live takes almost 24 hours to scan my music collection (28,000 mp3 files), rebuilding the library in this way is really not an option.

DLNA is at best hit and miss and udnp is a mess .

Being unfamiliar with the duo iam not sure but can you use ntfs and a access protocol?

This seems to be the same problem I am having.  I am not as technical as you guys but I will try to explain my situation.

The media library nevers seems to finish compiling, but i dont get any error messages at all

Setup: 2 WDTV SMP 1 with media Library on, the other off until I can get 1 working.  A 2TB USB Lacie drive connected and shared via a Asus RT-N56u router.

I have added the the shared folder  “movies” from the drive and the WD starts to create a library.  It finishes with no errors, but there is nothing in the media library.  I get the “there is no content in this folder message” or something like that.

When I navigate to the folder I can see the .wdtv folder and 2 files “wdtv.cas2” and wdtv CAS2-JOURNAL File"  I have tried deleting this folder completely and starting over again with no success.

I have rebooted and reset the WDTV SMP several time to start from scratch and get the exact same results every time.

One interesting thing i thought was these files are always the exact same size every time.  The wdtv.cas2 is always 43kb and the other 5kb.  To me that would mean it is failing at the exact same point every time, but that is just a guess.

I should note that the media player plays my media fine when I navigate to it through the network share option, and i dont believe that there is any read write issues since it can create the .wdtv folder and start to create a library.

I am looking for any help with this because I would like to see the library function work

perieradap:  That’s good information.

The fact that there’s a Journal file left behind indicates that the Compiler process is crashing out or losing contact with the storage during the compile process.

Unfortunately, the WD will NEVER give an error message that is meaningful.  About the only thing the “Status” will indicate (when looking in the media library manager) is “Internal Error” which is not at all useful.

The only suggestions I can offer are:

  - Try compiling the media library with the the drive connected directly to the WD instead of via the ASUS.

  - If that still doesn’t work, try moving some of the media off the drive and see if you can narrow down what file(s) may be causing the issue.

BTW, the fact that the CAS file is only getting to 43kb is interesting, too – unless there’s only a few dozen files on the disk.

My CAS file(s) are usually in excess of 2 megabytes.

I am going to try to compile the library with the external drive directly connected.  Is your thought if that works then i have a working library to start with and I can connect it back to the router as a share?

I will let you know what happens

pereiradap wrote:

I am going to try to compile the library with the external drive directly connected.  Is your thought if that works then i have a working library to start with and I can connect it back to the router as a share?

That’s it in a nutshell.

It may even work “normally” for a while – however, if it does work when directly connected, then I would be suspicous of the stability of the database when it’s back on the router.  

I got it working, but no exactly the way I wanted.  Here is the situation.

-The external drive has a whole bunch of folders in it.  Music, Family pics/movies, documents, and TV shows/movies.

As soon as I hooked up the drive directly to 1 of the WDTV boxes it started to creat a media library for the whole drive.

-It successfully made a library for the whole drive

-When I was having my issues I was adding/navigating to only the TV shows/movies folder on the WDTV box and the library always failed.  I really only want access to the TV shows/movies, I dont need access to all the other stuff on the drive.

-I have connected the the external drive back to the router and have enabled the media library on the other WDTV box.  Instead of navigating to the TV shows/movies folder, I added the whole drive and it started compiling its own library now…I have a uniondb.cas file now.  I guess that is both media librarys “unioned” together.

This is okay, but not great. When I go to videos on the WDTV, it shows every folder on the external drive that has a movie, could be family stuff, some movies from work etc.  I only want the tv show/movies.

Just curious has anyone hooked up an external drive to the WDTV box but only had a media library enabled on a certain folder?  I might need to do this over again, but would prefer to only create a library for the stuff I want, not the whole drive.

You can’t “index” only specific folders on USB drives that are attached to the WD…   It’s an all-or-nothing approach.

It seems odd that the WD can sucessfully index the WHOLE drive via network, but not specific folders.

I haven’t seen that issue on my NAS, at least…

Now it only indexed the whole drive via network after a library had been built with it connected directly.  I wonder If i should start from scratch and try to index the whole thig fresh from the network to see if I get any issues.

It’s academic really – just an interesting note whether it works or not.  :)