Sticky (but disconnected) Mapped Drives

Disconnected but previously mapped network drives are still showing up in Win8.1Pro Explorer (File Manager)

Admin account Explorer does not show them but the User account does.

WD Discovery “The local device name has a remembered connection to another network resource”

This problem originally occurred when I decided to use the WD Discovery applet to map to the WD MyCloudEX2 drives “automatically” (i.e. “Would you like to map the network shares automatically? Click “No” to map the network shares manually.”). Now I can’t take back that grievous mistake, no matter what I try in my Win8.1Pro machine!

Here are but a few of the attempts that failed!

Could the automatic mapping feature that assigns drive letters do so with persistant=YES?

Since the drive letters are shown to be disconnected (dreaded- Red-X), how can I disable the persistant=Yes flag, since I can’t access the mapped (but disconnected) drives?

I have read through all 21 pages of the posts and have tried every option but I don’t see a post for resolving this issue

Here are some attempts to remove these disconnected but previously mapped drives:

Reboot << NFG

File Explorer >> Refresh << NFG

net use X: /delete << NFG

net use /delete \\root$ <<NFG

TaskManager >> EndTask=Explorer >> Restart Explorer << NFG

(The proper context of the ‘net use’ command is here >>

Have you tried Right-Click> Disconnect Network Drive?

Life would be great if microsoft Win8Pro made it so simple!

Context sensitive right click menu has no such ‘delete’ command for mapped (but disconnected) NAS drives (at least in my system).

I even deleted Registry mount points using regedit (and rebooted) with NO SUCCESS!:


There are multiple places in the registry for “MountPoints2” thus requires searching for them.

If others are having similar problems, the entries that start with ## can be removed with little worry!

But doing a back-up of the registry before starting (even a setting a restore point) is highly recommended!

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

1 Like


I would highly recommend not using “WD_Discovery” utility’s automated drive mapping to and assigning winOS drive letters to your WDMyCloud HDDs (and user created ‘Shares’). I make this suggestion because this auto-mapping employs the “/persistent:yes” switch in the console shell ‘net use’ command. This causes the drives/shares to be remembered (sticky aka persistent) during subsequent OS boots. Unfortunately, since the “UserName” and “PassWord” do not appear to be added to the console ‘net use’ command (during the initial auto mapping), the subsequent boots cause the dreaded Red-X for each of the mapped drives/shares, in the FileManager.

using the instructions of WD ID 6745: “Error: ‘Unable to reconnect mapped network drives’ occurs when Windows attempts to reconnect a Mapped Network Drive after a reboot” I created a batch (*.bat) file and put it in the WinOS StartUp folder to undo the ‘net use’ command "persistent:yes’ switch first.

You have to follow the directions in ID 6745 to create the batch file named “mapped_drives.bat”

You have to determine the DriveLetter(s) assigned to your WdMyCloudEX2 drives that are showing the dreaded Red-X

You have to determine the IP of the WDMyCloudEX2 first (mine is \ as shown below in the batch file created.

You have to also find out the exact name of the drive/share that has the dreaded Red-X (disconnected but mapped)

You have to correctly mind the quotation marks and spaces as shown below in the batch file created.

You have to correctly input the “UserName” and “PassWord” that you use to log on to your WDMyCloudEX2 device

My example:


@echo off

net use Y: “\\SmartWare” /user:UserName PassWord /persistent:no

net use Z: “\\Public” /user:UserName PassWord /persistent:no


After the next boot, the batch file [hopefully] will remove the dreaded Red-X from the mapped drives.

This will allow you to delete them, using the console command by entering:

net use Y: /delete

net use Z: /delete

Now you can safely remove the “mapped_drives.bat” from your StartUp folder

And reboot again to confirm that there are no more dreaded Red-X mapped drives/shares in your FileManager.

Finally, you can use the “WD_Discovery” utility to manually assign DriveLetters to the desired drives/shares as you wish them to be mapped.

If you want these drives/shares to be automatically assigned at/during each boot you can change the “net use” command switch to “persistent:yes”. But you must remember to make sure that these local LAN IP addresses are fixed (static) as show in my case/example (i.e. \