Startup Repair cannot find hard drive

Hi all

I am at a complete loss. I booted my computer the other day and it froze at the login screen. I restarted and after POST it claimed BOOTMGR is missing. Naturally, I inserted the Windows 7 64 bit disc and launched to startup repair. But it cannot see my hard drive.
The hard drive is visible in BIOS, when plugged into another computer it opens in Windows Explorer, I have tried SATA-IDE and SATA-USB cables, I have tried legacy IDE mode, I have laoded driver after driver from my motherboard disc and website, I have used a different compuetr all together. Nothing seems to be able to get startup repair launched.
After this, I said “bugger it” and attempted to reinstall Windows from scratch- it still cannot find the hard drive. I had no problems originally installing Windows.

I have run Western Digitial Diagnostics on the hard drive and it passed with flying colours. I don’t want to send the drive back as it passed diagnostics and still opens in Windows Explorer.

I’m using a WD1500HLFS-01G6U1 drive (WD 150GB 10K RPM Velociraptor) and a Gigabyte GA-X58A-UD7 mobo.

Does anyone have any ideas of what to try? I am desperate at this stage.


I’ll suggest to completely zero out and clean the drive with DLG to try to install Windows again. Also try to install it on another drive (Before you zero out this one) to check if the installation disc itself is not working.

Thanks for your reply. As I mentioned, I was getting to the stage of doing that.

It seems to be working at this stage. What I did was managed to get to advanced boot options and startup repair from there- however it found no problems. I then continued to load Windows and I got BSOD- Config file error. So when I rebooted it, it launched into recovery and repair. It did its thing and once I got into Windows I scheduled a disk check and backed everything up.

To this point I have no idea how it was fixed or why it went wrong.

At least you got it working in the end :slight_smile: