SSH File Transfer Protocol (SFTP)


#1

Does My Book Live support SSH File Transfer Protocol (SFTP)?

If yes, how to enable it?

Thanks


#2

Nope.


#3

Thanks!


#4

you can ssh into mybook, if thats what your looking to do. Check out this thread http://community.wdc.com/t5/My-Book-Live/Telnet-or-ssh-my-book-live/td-p/87065


#5

I am searching an alternative method to access files remotely other than MioNet and FTP.

Any good suggestion? 

I have tried to enable SSH but http://mybooklive/UI/ssh didn’t work. It brought me back to normal UI login page.

Also tried export configuration file  -> change to “enable” -> import. But, I don’t know how to conrifm whether

SSH is enable or not.


#6

I got what you mean!

After enable SSH, I managed to access files in MBL remotely from external network through SFTP connection using

WinSCP. However, the user name and password seem “too friendly”. I have tried to search any editable file that contains

these information, but can’t find. Any idea?


#7

Just for you, guys, to know, WD does not advocate making changes through SSH to the drives; as this may cause damage to the drives.

[Edit]

If you are having issues with the drive, you may want to contact Tech Support for further help.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en


#8

Noted with thanks!


#9
  • Activate SSH

  • Use Filezilla, on root account with sftp protocol.

  • Painless.

More details:

Just activate ssh.

Log in (using ssh) as root. (ssh root@drive_IP ; password is welc0me)

Change password using passwd

log out. 

Using Filezilla, connect to the drive as root ; your_new_password ; with sftp protocol, port 22.


#10

Can anyone whisper how to make sftp possible not just for root (who uses root account for file transfering??? doh), but for other shell username which I choose ?


#11

I haven’t tried this on the drive. But it should be possible and easy to add users with the command useradd.

Then, you can connect to the user account the same way you used to connect as root.


#12

Wow !

It works just fine !

sftp -P PORT username@MyBookLiveIP

^ Was able to connect from outside my network from other linux box.

Great !


#13

so, just for others to know : how did you manage it ?

did you use “useradd” or did you proceed through an other way ?

I ask the question, because users that you create through the web interface are automatically added as unix users, so you wouldn’t have to do anything but the ssh user@your_drive_IP to connect as user.


#14

@U-PID: actually i don’t remeber how I created shell user (with useradd or with web interface).

It was while ago.

sftp was probably working all the way , I just totally forgot to use custom port for sftp connection (changed default ssh port on mybook live).


#15

Ok.

Thanks anyway.

I did bet that it was already working by default, however we will never know. I also changed the port and something similar happened to me.