SSH fails with Firmware 2.31.193

My “My Cloud PR4100” updated to firmware 2.31.193 and now I can no longer SSH to it.

I’m very familiar with the process and have been doing it quite a bit but as soon as 2.31.193 installed, SSH always fails on the login. It connects, prompts for password but rejects the valid password.

Things I’ve tried:

  1. Reboot the PR4100
  2. Turn SSH off and back on again
  3. Reset the SSH password
  4. SSH from Windows 10
  5. SSH from Mac OS
  6. putty from Windows 10

And nothing can login. Again, I can connect, and get prompted for the password but regardless what I enter, the password is rejected.

See the dedicated subforum for the PR Series where people more familiar with that device may be able to assist and where there may be past discussions on similar issues.

For example there is a discussion from a few weeks ago on an SSH problem with the 2.31.193 firmware on the PR Series.

If possible try rolling back the firmware to the previous firmware version where SSH worked and see if it fixes the problem.

Thanks! The solution was in the PR Series group and they said to use the sshd alias instead of root and that worked fine.