SSD Dashboard Unknown Error(0x2efd) during install

Howdy,

I installed a new WDS100T3X0C (1TB SSD) without issue. Win10x64 running fine. BIOS all good. Hardware all good. Very clean system.

But, every time I try to install the dashboard, it shows a little popup with “unknown error(0x2efd)” and an Ok button that makes it just go away.

Tried re-downloading it from the WD site twice (from: https://support.wdc.com/downloads.aspx?p=279). Logged in as admin user. Even ran the WesternDigitalSSDDashboardSetup.exe as Admin. Always the same result.

Strangely, I tried downloading the same file on a Win7x64 machine and tried running it (even thought it doesnt have a WD SSD) and get the same error. This kinda suggests a problem with the install file on the server. But, its from 2+ months ago. Hrmm.

The only real common denominators (except for them both having all WD HDs, and AMD CPUs) is that they both are running TinyWall (firewall) and NOD32 (AV). I have completely disabled both, and even whitelisted the Dashboard app (and all its dependents), with no change. First time installing on both. Ran in compatibility mode, etc. Nadda.

Any ideas?

Thanks!

AND, if you go to the Support section of the site and navigate to the Black SSD section, it shows a 16 month old version (v2.4.0.0) of the dashboard. Really?

https://support-en.wd.com/app/products/product-detail/p/1534#WD_downloads

Anybody have a link to the full (offline) installer file for 2.7 (or even 2.6) - and not the 3 meg web installer junk?

WD support has been everything short of wonderful.

Thanks!

Ok, if you got here by searching Google for a solution to not being able to install the SSD Dashboard, dont waste your time contacting WD support. They are pathetic.

They have no interest in resolving your issue and would rather have you jump through hoops (like a circus show) than provide anything resembling useful support. My favorite one was them asking for a screenshot the dashboard!

Just download the old installer here:

https://fichiers.touslesdrivers.com/61098/WesternDigitalSSDDashboardSetup.exe

If you have any more problems, run it as Admin, temporarily disable your AV and Firewall (or just whitelist the installer instead) then try again.

When I terminated my firewall, it immediately passed the installer and successfully installed after error code (0x2efd). As it turned out later, this is a webinstaller, only wd didn’t feel important to communicate this.

Hi Musixz,

Please be informed that while installing WD Dashboard I had also encountered this same error code 0x2f7d - unknown error.
I searched Google and found that it’s an Microsoft store error code (0x80072f7d)

It got resolved by performing this simple steps as below:

  1. Open Network and sharing centre.
  2. Click on internet options.
  3. Click on advance tab.
  4. Scroll down to see if under security - box for USE TLS 1.2 is CHECKED (Ticked)
  5. Click OK. DONE!!!
  6. Restart your PC and install WD Dashboard setup file and it will work.
    For more info. please visit this link: For error code 0x80072f7d

Thanks & Regards,
Abhishek Pol.

1 Like

Thanks for the follow-up, but I checked on both machines and the Use TLS 1.2 is/was checked on both - so that was not my issue.

That you trying to provide a viable, possible solution. It’s so much more than WD ever did.

WD Support still ■■■■■ horribly!

Thanks for the answer it resolved my issue