'Some' MKV files not playing on WD HD player

On my WD player, I noticed that some MKV files plays fine, while some of them does not play when selected … i.e the time bar shows as 00:00:00/00:00:00, and fails. 
After the WD fails to play a file, it does not play any other file (that used to play before) unless I do a factory reset. 

Anybody has a similar experience? If so, is there a way out? 

Please note : This started after I upgraded to 1.02.21 … When it was on 1.01.12, it used to work fine. 

1 Like

See FAQ section 4H.

http://community.wdc.com/t5/General-Discussions/WDTV-FAQ/td-p/32135#playback

1 Like

Thank you.

Wow, what an incredibly useful response! I’m so glad I Googled this as I’d started to experience the same problems and it was really frustrating.

I downloaded the latest version of MKV Merge as suggested and remuxed a small file in seconds and it worked perfectly on my WD HDTV Live unit.

Will try on a large file and feedback.

The only thing you need to watch is what version of MKVmerge you’re using.

v4.1.x will default to compressing the header of the audio track.

v4.2.x and higher will default to compressing the header on both the audio and the video track.

So if, for instance, you’re using v4.3.x to “fix” a file that has compressed headers in the audio track (made with 4.1.x), and you only select Compression -> None for the audio track(s), then you’ll end up compressing the headers on the video track and still have a “bad” file.  Just make sure if you’re using any version 4.2.x or later, that you also turn compression off for the video track, whether the video track originally had header compression, or not. :wink:

Remuxed an 8gb .mkb in about 15 minutes and it now works flawlessly. Thanks so much for your useful information.

I did. I turned off compression for everything!

The time all boils down to the speed of your drives and of your computer, and what else you’re doing at the same time.

Mine seems to average about 30-45 seconds per GB when I’m not doing much else… I’ve rarely had a file take longer than 5 minutes.

But glad you’ve got it sorted out. :smiley: