SOLVED: WD TV LIVE STREAMING with iMac Snow Leopard problem

I just recently bought WD TV LIVE streaming which I planned to connect with my iMac (10.6.8 Snow Leopard). At first everything was okay. I have a WiFi network at home with a router serving an iMac in my study and a MacBook in the dining room. I could connect my WD TV LIVE easily to my WiFi network and after setting my SMB shared folder in my iMac (SYSTEM PREFERENCES, SHARING, clicked FILE SHARING, added SHARED FOLDER, clicked OPTIONS, clicked SHARED FILES AND FOLDER USING SMB (WINDOWS) and clicked the designated account I wanted to share): no problem. I could enjoy the streaming of my music, photo & video (through VIDEO/MUSIC/PHOTO, pushed RED button (SELECT CONTENT SOURCE, and chose NETWORK SHARE and chose my iMac’s name, login, etc. in WD TV LIVE interface).

But this didn’t last long. Only after few days, the connection between my WD TV LIVE with my iMac became very unstable. I had to keep logging in to my iMac and then totally lost it after some attempts as if the signal is breaking. I looked through a lot of pages, including in this forum, tried 1001 ways but none solved my problem. However, along with my iMac problem, my old MacBook (10.5.8) has no problem at all with WD TV LIVE. I could see the shared folder and play it’s contents smoothly. After weeks of neglecting my iMac problem, I tried something, just try and error, and it surprisingly worked.

So far, when I wanted to play video, I always went to: VIDEO, pushed the red button (SELECT CONTENT SOURCE), selected NETWORK SHARE, selected WINDOWS SHARE and looked for my iMac (which most of the time appeared on the list but any login attempt would failed, or it just simply wasn’t there). This time it’s a different way:

  • Go to SETUP

  • Choose SYSTEM




  • Choose my iMac and LOGIN

And then, the WD TV LIVE’s power lamp was blinking for like 5 minutes as it scanning the contents of my shared folder (of 374 GB). When I went back to VIDEO menu, it shows ‘132 NEW ITEMS’ (the amount of folders I have in my shared folder). And so far, it has been 3 days, no problem at all. I turn on my WD TV LIVE and go to VIDEO, or MUSIC, PHOTO, I can see and play everything.

I never thought about choosing MY MEDIA LIBRARY because I thought this is a streaming media, it doesn’t have any internal hard drive. I didn’t realize that it can still compile database from a remote hard drive shared through a network. So there you go, if you had similar problem, I hope you can get it solved. Thanks for reading, everyone. :slight_smile:

1 Like

Great info, thanks for sharing