[SOLVED] WD MyNetN900+Realtek PCIe GBE Family Controller Compatibility Issue Conn.Prob.no IP

I got problems with connection on new mb MSI Z97 U3 Plus on which is used Realtek PCIe GBE Family Controller.

I can’t get IP from DHCP of the router.

I’ve made new fresh install Windows 7-64bit , tried drivers on dvd which came with mb, downloaded drivers fro msi web, downloaded latest drivers from realtek site, none of them helped me.

There was no conflict in device manager all drivers were fine, but when connected cable I get only ip 169.254.x.x even when I manually added my ip 192.168.1.x I get connected localy, but no internet.

On same router are other pc, nb, tb, mp connected and working. 

I tried even another LAN cable, but problem not resolved.

Restarted N900 router more times.

On router I got latest firmware Firmware Release 1.07.16 (5/21/2013).

But when I conected it to old Netgear router which is not conected to internet I get the ip address correctly.

I dont think that on new mb could be the LAN bad or?

Anyone have same problems compatibility with WD My Net N900 routers an Realtek PCIe Gigabit Controlers?

Can someone HELP me out with this problem PLEASE? THANKS!


Besides setting up the static IP have you also tried setting up the DNS?

1 Like

problem is solved I got wrong number for allowing mac address (I made mistake in last number of mac address was 0 and should be 9) for connected network card on router, thx for everyone bye :smiley: