[SOLVED] "Partition not writable" under Windows 10 but fine under Windows 7

I think I have new twist to the “No writable WD Smartware Partition Found” problem that many people have reported here. Unfortunately, while reading through the forums, I have not found a solution for the problem.

I have an MyPassport Essential external HD with the latest firmware and I have installed the latest version of WD Smartware on my Windows 10 machine after deinstalling the old version. However, I get a “No writable WD Smartware Partition Found” message when trying to access the drive through WD Smartware and I cannot see any of the files that I have saved on the disk. Interestingly, when I put the same drive into an old Win7 machine, everything works like a dream. So the problem is not with the drive itself but with how WD’s software accesses it under Win 10.

I guess I could connect yet another external drive to the Win7 machine and move all files over (there is not enough space on the Win7 machine) but I don’t have another harddrive at the moment and buying a new one just to move the files off feels a little ridiculous.

Has anyone experienced the same issue and found a solution?

Thank you!


Do you have to use WD Smartware?

Try using WD BAckup. Download it from the downloads tab at the top of the screen. You will also need WD Discoveru, WD Security and WD Drive Utilities.


Hi Clifford! Thank you for the suggestion. Unfortunately, that doesn’t seem to help - or I don’t know what to do with these programs :-). The files I have saved on the drive have not been saved as an update archive but were simply files and folder I had moved to the hard disk from my computer.

I just installed the four programs that you suggested.
Drive Utilities tell me that the drive is ok (SMART and quick test).
Discovery says the drive is “read-only”
Backup doesn’t find anything on the drive
Security is not doing much since the drive is not locked
Smartware still says the partition is not writable

Any other ideas? I think the problem is that under Win7, the pre-installed software on the harddisk basically “spawned” a virtual drive on which I could see all my files. But it is not doing that any longer. Something is missing somewhere that triggers that process.

I have used the Virtual CD manager to toggle the settings for the drive but that did not result in any changes.


The solution was very different from what I thought it would be, yet very simple. I simply had to manually assign a drive letter under disk management in Windows 10 and it worked.