[Solved, I think] Cannot browse the MyWDCloud in Windows 10 only Windows 7

#2

Have you set everything up in the Dashboard? Is it in the same workgroup?

Does it show under Network?

image

#3

No, it does not show up under Network in Windows 10, only in Windows 7. In Windows 10 it is a separate icon, not a device in a tree and when I double click on it, it just goes to the browser interface. I cannot browse into it in windows explorer. What do I need to setup in the Dashboard? Is that the web interface? Why does it automatically show up and be browseable in Windows 7 but not Windows 10?

#4

#5

@eteune
Have you tried a right click on it and then click on Open?

image

#6

#7

This is all I get

#8

Try a reboot of your router and see what happens.

I have Windows 10 with all updates and I have not had any problems using my My Cloud 1st generation.

#9

Same workgroup, just will not work in Windows 10 for some reason. Never had this is problem with Seagate. Rebooted PC, rebooted drive. Same problem. Just bought this a couple months ago. Maybe the newer ones just don’t work right or they are forcing us to only use the web interface. Never again. Back to Seagate

#10

Is there any type of support for these things? Or are we talking India/Philippines, run around, did you reboot type questions for 5 hours?

#11

@eteune
Do you have Network Discovery on? Click on, tap or activate image to enlarge it and see complete image.

#12

Did you use Seagate with windows 10?

Since your device works with the windows 7 machine, it is clearly a problem with the settings on the windows 10 machine, not a MyCloud problem.

Try the suggestions in this thread:

#13

yes, network discovery is on and have been over that thread with a fine toothed comb. It sees the device, it just cannot browse into it. Why are there so many issues in Windows 10 with this device? Did they not test it properly before shipping it out to the market?

#14

and just re-reading that entire thread on Windows 10 issues makes me laugh, they really, really did not think this product through before releasing it, the hoops they are expecting people to jump through to get this thing to work is unbelievable.

#15

Here you go: from the comments of those Windows 10 instructions "As far as the current issue of the WDMyCloud(s) not showing in the [Network] list, this has not yet been addressed in a firm release. However, there are beta tests ongoing that we hope will finally fix that bug.

I believe I have found a work-around for this bug but it requires some knowledge of Windows networking, running commands at the CMD prompt, and having a Linux device on your network (computer or router). I am willing to communicate this work-around to interested Windows 10 users who meet the above requirements."
unbelievable!

#16

So I am still not sure what finally worked, but after I went into device management, drilled down in properties, Change Properties and updated the driver THERE

#17

I don’t know; ask Microsoft…?

This product predates Windows 10.
As you have observed, it works fine with Windows 7.
When I trialled Windows 10, it worked perfectly, and I had no trouble mapping the MyCloud shares as network drives, just as I do on my Win7 machines.
I chose not to adopt Win10, and am still running Win7, with no problems.

It isn’t a case of jumping through hoops to get the MyCloud to work with Windows; it is the problem that Windows has a lot of settings for its network connectivity, any of which can prevent a network device being seen.

All the methods that Bennor has kindly collected to help fellow MyCloud users are aspects of Windows network configuration, not of the MyCloud configuration.

WD aren’t responsible for your Windows network configuration. What they might do is create a tool to look at a Windows network configuration, and suggest why it might be preventing access to a MyCloud. But you, as administrator of your Windows device, are responsible for the network configuration of your Windows machine. You might equally ask why Microsoft make it so damned difficult to configure their network settings to allow their OS to connect to a network file server.

#18

The My Cloud devices PREDATE the release of Windows 10.

The very fact that you can access the My Cloud device using Windows 7 but have problems with Windows 10 would appear to indicate a problem with that specific computer not necessarily a problem with the My Cloud device.

Don’t know if this has been suggested yet but have you tried accessing the My Cloud using it’s IP address in Windows File Explorer?

Try disabling any security software or firewall on the Windows 10 PC as a troubleshooting step.

#19

What device on your network has control as the ‘master browser’? If it your Win 10 box then you will likely not be able to browse the WDMyCloud.

#20

Go to “Control Panel -> Programs”
Select “Turn Windows features on or off” (requires admin rights)
There you will find “SMB 1.0/CIFS File Sharing Support”. Enable it!

That’s all

#22

Further Microsoft explains why SMB1 is vulnerable and why they disabled SMB1.0 in Windows 10 in the following post(s):

https://blogs.technet.microsoft.com/filecab/2016/09/16/stop-using-smb1/

https://support.microsoft.com/en-us/help/4034314/smbv1-is-not-installed-by-default-in-windows