SMB used in WD N900 routers

Hi everyone,

Well, after several hours spent on it, I think I have managed to solve a lot of problems I bumped in with the N900 router. 

But I still have one issue I can’t fix. 

Here’s the problem. 

I would like to access the files stored on a USB hard drive connected to the N900 to stream them on my Blu-Ray player. 

The BR Player can access the network using Samba. 

Once powered up, it lists my N900 routeur as a file server. 

But if I try to connect to it, it asks for an ID, and whatever setting, I always get an error message “User and/or password unknown”. 

I have set the N900 to share the USB content only to a special account : no go with the L/P i’ve enterde. I tried to let the USB share to “Public” and left the L/P on the Blu-Ray player empty : no go. Tried the latter with “Guest/“blanck”” : no. Tried it with “Guest/guest” : still no go. 

Which leads me to a question. I experienced the exact same problems when I tried to share content on from my Mac. After some research it turned out that this was due to the implementation of the MSB protocol into MacOsX. 

If I reinstall the “genuine” SMB protocok into my OsX 10.8.2 Mac, it works like a charm…

So I was wondering if anyone knows if WD has implemented the “genuine” developped SMB protocol, of it they have loaded an implementation of their own…



Have you tried accesing through the media server?

Hi Ragdexx,

Yes, I did try that, and that works. 

But DLNA is not the purpose of the router.

DLNA may convert your files.

And I want to make sure that the file I’m watching or listening is in the correct format and not a .flac converted to .mp3. Thus the need for SMB.

DLNA is not as convenient as SMB.

Some features do not work with DLNA. On my Blu-Ray player, if I rip my Blu-Ray do a hard drive and put the files in a folder called “AVCHD”, then the player recognizes the structure of the Blu-Ray and I can enjoy it with menus, chapters and languge/subs selection. Over DLNA, I can just browse through folders, make sure to get to the “STREAM” forlder, find which contains the main movie (if it’s not split) and pray that it will be in a format that will be recognized by the DLNA server ! 

Besides, DLNA has this sorting based on tags which forces you to give really accurate tags for your files, or you’ll end up finding nothing you’re looking for :frowning:

I experienced that several times with almost all DLNA media servers, the worst being Twonky. 

I don’t even know what media server is used for DLNA in the WD and will probably never know :frowning:

So unless I can find a way to get access to my files through SMB, I fear that this will have to make it’s way to eBay or some other SH ad site :frowning:

So far, I’ve tried several routers and NAS’es from different manufacturers. They all seem to have a glitch. WD obviously uses a self made SMB server. Netgear has boviously a problem handling a mixed-up environment where there are Fast and Giga Ethernet devices. Apple’s Airport Extreme on ly has 3 Gigabit Ethernet ports when I need at least 5 (I have added a switch andthat works, but is inelegant in my room !). Both Netgear and WD do not support my 4 hard-drives bay over USB and recognizes only one of the hard drives. The APple Airport Extreme know how to handle this perfectly.

The best solution I found is the LaCie NAS calle d"Network storage". But that a NAS and no router, but it’s content can be accessed via SMB without a problem and when connected to a switch, streams seamlessly to the Universal player. 

So, based on all this I assume the pefect solution COULD exist : a simple router based on the hardware of the Apple Airpot Extreme but with 4 additionnal Gigabit Ethernet ports and 1 additional USB port. And I would be in heaven. I’ll give the LinkSys routers and D-Link routers a try if I can’t get the WD to work properly and share my USB drive through SMB.