SMB/FTP Help Needed


Wonder if anyone can help, I’ve been tearing my hair out trying to map my new MyCloud 6TB drive to Windows 10 Home and also to FTP into it via WinSCP.

  1. Windows 10 SMB Access

I have set up a share called Lossless_Music copied my music to it from an existing NAS and mapped it to a Windows 10 drive using SMB but I can’t edit anything other than one level down in Windows e.g.

Lossless_Music (\\ (Z:)\A
Can edit

Lossless_Music (\\ (Z:)\A\Afghan Whigs
“Folder access denied - You require permission from Unix User/ftp to make changes to this folder”

It’s almost like Windows is only applying the permission to the top level folder.

I have a QNAP NAS and it works fine over SMB, anyone know how to resolve this?

Full Setup Details:

Windows 10 Home Edition

Advanced Sharing Options

Network Discovery - ON
File & Printer Sharing On
Homegroup Conn - ON

Guest or Public (Current Profile)
Network Discovery - ON
File & Printer Sharing On

Map Network Drive
z: \\\Lossless_Music
User: admin
Pass: As WD Drive Sign In

WD MyCloud

Network Settings

Network Profile

Status - Internet access
Mac Address - ####
IPv4 IP Address -
IPv4 DNS Server - ,

Network Services
IPv4 Network Mode - Static
FTP Access - ON Configure>> Port 21

Windows Services
Workgroup - WORKGROUP
Local Master Browser - ON
Max SMB Protocol - SMB 3 (*Have also tried 1 and 2)

Port Forwarding - No port forwarding service(s) has been added to your WD My Cloud device.


Share - Lossless_Music
Desc - Collection of FLAC Music
Public - Off
Media Serving - On

Share Access
FTP Access - On (Anonymous Read/Write)
NFS Access - Off

User Access

admin - read/write
ryanmcrae - read/write

  1. Secondly FTP, I’m using WinSCP as I thought this may be another way to access the contents for editing purposes but I just can’t get it to connect


File Protocol - FTP
Encryption - No Encryption
Host Name -
Port No - 21
User Name - Anonymous (*Have also tried admin account)

Again I can access my QNAP NAS on via WINSCP.

Have I set something incorrectly?

Thanks in advance


Got into the device using SCP on WinSCP after switching on SSH, but cannot get FTP to work.

Following other advice here I have changed my network location to private from public. Still no joy on being able to edit files though.

I can edit files on the WD My Cloud application but I need to be able to use a Media Tagger to fix the FLAC/MP3 tags hence I need to be able to map a drive.


Some more info, I ssh’d via Putty and copied the permissions for Lossless_Music

root@WDMyCloud A # ls -la /mnt/HD/HD_a2/Lossless_Music
drwxrwxrwx 10 root root 4096 Mar 16 15:09 #
drwxrwxrwx 30 root root 4096 Mar 16 16:19 .
drwxrwxrwx 12 root root 4096 Mar 16 15:30 …
drwxr-xr-x 70 ftp 95 4096 Mar 14 19:55 A
drwxr-xr-x 127 ftp 95 4096 Mar 14 22:40 B
drwxr-xr-x 81 ftp 95 4096 Mar 14 23:53 C
drwxr-xr-x 78 ftp 95 4096 Mar 15 00:59 D
drwxr-xr-x 38 ftp 95 4096 Mar 15 01:14 E
drwxr-xr-x 55 ftp 95 4096 Mar 15 01:52 F
drwxr-xr-x 52 ftp 95 4096 Mar 15 02:18 G
drwxr-xr-x 54 ftp 95 4096 Mar 15 03:36 H
drwxr-xr-x 18 ftp 95 4096 Mar 15 03:53 I
drwxr-xr-x 45 ftp 95 4096 Mar 15 04:46 J
drwxr-xr-x 31 ftp 95 4096 Mar 15 05:38 K
drwxr-xr-x 60 ftp 95 4096 Mar 15 06:18 L
drwxr-xr-x 77 ftp 95 4096 Mar 16 01:33 M
drwxr-xr-x 33 ftp 95 4096 Mar 15 13:40 N
drwxr-xr-x 25 ftp 95 4096 Mar 15 13:58 O
drwxr-xr-x 77 ftp 95 4096 Mar 15 15:16 P
drwxr-xr-x 7 ftp 95 4096 Mar 15 15:29 Q
drwxr-xr-x 29 ftp 95 4096 Mar 15 23:57 R
drwxr-xr-x 133 ftp 95 4096 Mar 15 18:16 S
drwxr-xr-x 59 ftp 95 4096 Mar 15 18:43 T
drwxr-xr-x 14 ftp 95 4096 Mar 15 18:54 U
drwxr-xr-x 20 ftp 95 4096 Mar 15 19:11 V
drwxr-xr-x 253 ftp 95 16384 Mar 15 22:24 Various Artists
drwxr-xr-x 31 ftp 95 4096 Mar 15 22:57 W
drwxr-xr-x 5 ftp 95 4096 Mar 15 23:01 X
drwxr-xr-x 11 ftp 95 4096 Mar 15 23:13 Y
drwxr-xr-x 9 ftp 95 4096 Mar 15 23:56 Z

To me it looks like there are missing write commands.
Does that help anyone advise why I can’t modify files when using the share as a windows 10 network drive?

I’m not a 100% sure, but for FTP, don’t you have to port forward? For editing, I would try putting one of the media folders into the public share and see if you can edit there. That should eliminate pc-side network issues.

The ownership of folders under shares are normally ‘nobody share’, not ‘ftp 95’

I suspect you tranferred your media to the MyCloud using FTP, so they are owned by an FTP client login, not an SMB client login.

Hi Guys

Yeah I used cloud connect on my QNAP NAS to do it via FTP so that at least explains that.

Subsequently to my last post I used CHMOD and CHOWN to change the permissions to 775 and Root, which kind of worked but then when editing on Windows I got the WDMyCloud/Nobody message as mentioned.

Based on some other chats on this board I moved everything back to the public folder, deleted the share and created a new one called MUSIC with read/wrote permissions fotr my admin account; which i then moved the data to. Now I can access and edit my # and A folders down to the files

e.g. Music/A/Anthrax/1987 - Among The Living/01 - Madhouse.flac to … 01 - Mad House.flac

However for B-Z I can only edit one folder down

e.g. Music/B/Bad Religion to BadReligion

“Enthused” by the fact that it partially worked I’ve checked the folder permissions and I can see the issue

Music/A - drwxrwxrwx all the way to the files
Music/B - drwxrwxrwx to Artist Name and then drwxr-xr-x from album to files.

Owner is root:root on all folders

Am I right in thinking that if I ssh in and run chmod 777 -R B and repeat up to Z from the Music folder this should fix my issue? Would I need to unmap and remap the drive from Windows?