SMB 3 not working on WD PR2100

Hey Guys,

Im having trouble with SMB3. I got it working on my Synology DS920+ and my PC with transfer speeds at 2gb, but its not working on my WD PR2100. I have tried these settings as seen on the screenshot below. Any help would be appreciate.

Screenshot 2023-06-04 at 3.49.43 PM


can you explain better what you are trying to accomplish and what exactly isn’t working?

It looks like you have enabled both SMB2 and SMB3, why don’t specifically set it to SMB3 and see if it works at all?

Hey John, I tried just SMB3 and i didn’t get the full file transfer speed. The WD PR2100 user manual isn’t to clear on setting up SMB3. I have 2 Lan cables with LAG turned off. The screenshot below shows SMB3 in full transfer speed at 219 MB/s with my Synology DS920+ to my Dell PC. For some reason my WD PR2100 wont transfer at the full SMB3 file transfer rate.

Screenshot 2023-06-05 at 3.24.17 PM

But 219MB/s equal 1,75Gbit, so 2Gbit/s.

LAG must be turned on there.

1Gbit gives you real speeds around 110MB/s

Hey John,

I turned on LAG and it passed the test on my PR2100 as seen in the screenshot below and still it doesnt transfer at 2Gbit/s. :frowning:

This is not Link Aggregation but rather Share Aggregation.

Both Ethernet ports need to have there own IP address for SMB3 to work properly. So Link Aggregation is out of the question. But when i applied the Shared Aggregation settings, it says the test was successful but SMB3 is not transferring at its full speed.