Smartware won't see mybook live on network

A few days ago, I bought a Mybook Live 2Tb drive to use to backup our home computers. I have two laptops running Windows 7 and a netbook running Windows XP. I had trouble installing the smartware software on one of the laptops, and after almost 3 hours of level-2 support from an excellent technician from WD, we got it installed. Unfortunately, it doesn’t see the WD drive on my network. If you are a WD person reading this, my ticket number is . The tech logged into my laptop, upgraded my .net software, java software, upgraded the smartware to the most current, and I have also updated the firmware on the drive. The tech checked every setting in W7 to make sure nothing is preventing seeing the drive, and all is correct. I can see and access the drive on my system using explorer, and I also ran WD’s Netview, and it sees the drive and says everything’s fine. We tried it with my windows firewall on and off, with no different result.

As a followup, I loaded the software on a second W7 system and the XP system, and the situation is the same on both. I also called my router manufacturer, Actiontec, and they confirmed that if we can see the drive on the network, there is nothing in the router preventing software access. I also downloaded two trial versions of other backup software, and they both see the drive just fine.

I am very frustrated and disappointed in this situation. I bought the drive to do continuous backups of one of our systems and the software just won’t see the WD drive. I don’t want to have to buy someone else’s software to do what the WD software is supposed to do.

I have seen several other posts that discuss other issues with the Smartware not seeing drives. Does anyone have a solution to this problem? The fact that I have an identical problem with 3 systems suggests it’s not a computer based problem but rather a software issue?

Hi, you have provably tried this, but from the Smartware home tab, can you see the my book icon? If you press it, the backup/retrieve tabs should become accessible. Just to be sure you can also try using another router or even connecting the my book directly to the computer and see it it’s recognized.

I can see the icon but nothing happens when I touch it.
Thanks, any other ideas?

Followup: I was never able to get the Smartware program to work but WD support Sam sent me an alternate program which is not as pretty as Smartware but does work fine. Thanks to the level 2 support people who spent about 3 hours working with me on this and we did finally get something to work.

Regards Peter

What was the solution ?

Can you tell me what software they sent you and if this worked?  I am having trouble with Smartware too.

How did they arrange Level 2 support?



I called tech support and they gave me to a level 2 agent, which is the higher skilled level. They sent me WD Anywhere Backup as an alternate program. Its interface isn’t as pretty as the one which comes with the drive, but it does work fine.

Hope this helps.


I am having the same problem.  The drive shows up on my network and I can access it, copy files, etc etc.  But with SmartWare it does not appear.  I tried installing on another computer, same problem!  I tried uninstalling and reinstalling, nothing!  Has anyone had any other luck, or is the different backup software all that seems to resolve the issue?

Of course the response from WD is to try to reinstall…I didnt think of that!