Smartware icon doesn't give me access to drive contents

When I right click the smartware icon in the system tray, I can usually select “WDMyCloud” and then select “open”. Right now, when I right click, all I can access is the “settings” menu or the Smartware software itself. There is no option to choose anything to open up a Windows Explorer folder.

You can simplify the process and “map” the My Cloud in Windows File Explorer which makes accessing the My Cloud easier.

When Smartware is installed it also installs the WD Quick View program. It is the WD Quick View program that allows you to quickly access (as you described) the My Cloud even though you are selecting the Smartware icon in the task tray area. One could try reinstalling the Smartware program but doing so may erase the existing custom settings for the program if one has change the Smartware defaults.

One can try to launch the WD Quick View from one’s Start > All Programs > Western Digital > WD Smartware menu.

WD Quick View can be downloaded from the following link:

Thanks. Don’t like mapping.

I was wrong about the WD program its WD Quick View not WD Access. Although I think WD Access may perform a similar function. I don’t use any of the WD programs, rather prefer to map the drive. One can always place a short cut to the mapped drive on their Windows desktop to make opening the My Cloud easier.

But this has not been a problem before. It works on one computer and is totally missing from another. Why is on one and not the other? I right-click WD quickview and I can choose to either open a windows explorer folder that opens up the drive or WD smartview. One computer has the folder option. The other computer does not.

The answer is “network discovery”. It wasn’t turned on for some reason. Once I did, the option to open up the mycloud folder was there.