SmartWare cannot find MyCloud 3Tb as a target

Hi all,

My internal HD died. Installed Windows 7 from scratch. Today I installed SmartWare to retrieve some backups, and the SW cannot see MyCloud 3Tb. Of course, I had no issues seeing the drive and my shares before.

I have confirmed the following:
* MyCloud can be seen as a computer under Network
* WD Discovery finds MyCloud without issues as a NAS

* I have permanently mapped three of the shares I have.  Tried via WD Discovery and via Windows without success

* I can access my shares upon reboot

* Can access MyCloud’s Dashboard just fine.

* SmartWare can detect a direct attach MyPassport drive via USB as target.

Have tried restarting several times, uninstalling and reinstalling SmartWare, going through MyCloud’s setup… nothing works.  I have .Net 4, Java 7u51, MyCloud is at the latest fw release v03.03.02-165.

Any guidance will be appreciated.


Hi, see if you have any firewall active that might be blocking the access. 

Thanks for your reply,

It was enabled.  I disabled it for testing purposes, and still cannot see MyCloud from SmartWare  :(

Was able to find a solution with some help of WD support.

SSDP discovery never started.  Started the service along with UPnP (via services.msc) and that did the trick.  I had enabled UPnP on my router, but never checked it on the host until now.  After that, SmartWare was able to see MyCloud.

After doing this, I couldn’t see one of the shares that wasn’t mapped already, so I just disabled the firewall, mapped it and enabled it again.   

Now I have no problems and can run and retrieve backups.

hi schapp,

I wish I would understand what you wrote. Seems to be the solution - also for me, but as I’m not an IT guy, I don’t really understand what you wrote. Would you mind explaining in more detail. Or can I call you?



You just need to click on Window’s Start (lower left) and on the text box that says"Search Programs and Files", type: services.msc

Once in the Services Window, scroll to find the “SSDP Discovery” service.  Double Click it and change the start mode to automatic.   Cick OK.   Then repeat the process for “UPnP Device Host” and that is it.

Hope it helps :slight_smile:

I am getting exactly the same thing.  I’ve just been onto WD tech support and they told me to reboot everything (drive, router and PC) and just by chance it worked… the first time.  I rebooted the PC again and I am back with just the dropbox option showing.  I’ve tried the current suggestions on this thread but no luck.

On my old router I had something similar - my drive (a myCloud Mirror) was visible to the network as a share, but not to Smartware or Quickview (or at best I just got “wake this device” and “forget this device” as options) on the wifi-linked machines (but it was fully visible with all Quickview menu options on LAN-cable connected ones).

Root cause was the network speed - when I updated the router (an old Belkin b/g based one) to a new one (a Netgear 6200 b/g/n/ac one) the MyCloud instantly became visible to all the machines on my network.

It’s something you can simply test by disconnecting your drive from the router and directly connecting it to the ethernet port on your machine. If Smartware/Quickview can then see it fully, you may have the same issue that I did. If so then maybe some adjustments/tweaks to your network set-up may be in order.

I, too, continue to suffer through this problem with my MyBookLiveDuo.  Had a WD Tech Support guy set up my main Win7 machine, which connects with it no problems.  When I upgraded my wife’s PC to Win7, set up the network settings exactly the same way, but the only way I can reliably get SmartWare (and QuickView) to see the device is to reboot the MyBook.

Windows Explorer can see it just fine on the network (as do other devices in the house), and I can map shares to a drive from my wife’s PC, but Smartware as backup is not reliable for her. Since I can map a drive, I have an XCOPY backup run multiple times a day on her critical folders.

[edit] Oh, and this is with the latest 2.4.1 code