Smart tv

Hi I have been running the device for ages with a smart tv. The problem is now the tv recognises the my cloud device but keep saying there are no videos or pictures. The videos and pictures rub fine on tablets and phonesand i can see them when i conect it to a laptop. i have reset the tv to factory setting, the device gets picked up straight away but will not show any photos, videos etc.This has only happened in the last month. 

Help would be appreciated, normal connection via tv is wireless.

Have you tried rebooting both devices?

you can try to rebuild the database on the mycloud but I doubt if it will help

has your TV recieved a firmware upgrade? there have been a number of reports of this happening

if nothing above works try a system only restore, this resets it to like new condition except all shares and data are left in place

Worked fine, it just shows 1 sharer, do I have to set all the others up again before I can see them or how do I get it to share them again from the dashboard

I am not sure what you mean bty sharer.

is this the view media players in settings/media? I believe they will only show after they have been used to access the mycloud

what fixed it? the system only restore?

Yes system restore, it is only showing my files no one else’s on the TV at the moment, could be i have to set them up again as users. I am not sure how to get it to pick up the shared folder of videos. Thanks, great help so far.

users do need to be re-created after a system restore but this is not prenting the files to be seen on the TV

the system restore would have turned off media shareing on most shares, re-enable this on the shares the host media. you may need to rebuild the twonky DB after this but it should pick it up. depending on the number of files it could take awhile to finish scanning