Slow transfer speed to my WD mycloud via BT smart hub

I am using a BT smart hub router/hub (this hub has gigabit ports) and have mycloud connected. Everything is suddenly going at a snails pace. I am trying to copy files from a USB drive to mycloud and this is taking forever with the tranfer pausing from time to time.
I have been into the dashboard on Mycloud and this also seems to hang after a few clicks to do anything.

The top light on the rear of Mycloud is blinking green but the bottom light is solid yellow so from what I have investigated so far this means that somewhere I have just a 10/100 connection? Can anyone suggest how I may logically solve this problem?

First what is connected to what? Is your computer using WiFi? What is the USB drive connected to? The My Cloud or a computer?

Start by changing out the Ethernet cable to the My Cloud.
Try a different Gigabit networking port on the router.
Check the router model to ensure it really has Gigabit ports and that the My Cloud is connected to a Gigabit port.
Disconnect all other network devices from the router (including WiFi devices) but that one computer and text copy speeds.

If using WiFi speeds typically are worse than if using wired Gigabit networking.

Which model Home Hub is it?

Hi Thanks for you response.

In answer to your questions.

My PC is on the Ethernet connection via one of the four Gigabit ports on the router
The USB drive is connected on a USB 3 port on the PC
Yep this router only has Gigabit ports so the WD MC is connected to one also, so all on the same hub
The Wifi on the computer is disabled

I have tried a different Cat5e cable and swapped ports.

Contacted the ISP BT who really at first did not understand the question and then also suggested swapping the Gigabit port.

Under Network Properties in Windows CP it say Link Speed 100/100…I’m not sure what to expect really, but for Gigabit that does not sound right.

Thanks again

Its the so called Smart Hub (sometimes referred to as Hub 6)

No, that isn’t right. It is telling you that you only have a fast ethernet link (100Mbps). Use the device manager to find out exactly what ethernet adaptor your PC has, and then find out (Google) what it should be capable of.

No that’s not right and potentially explains your slow transfer speed to/from the My Cloud. As cpt_paranoia indicated you need to find out what kind of adapter your PC has and if it is operating and it’s fastest capable speed.

If the adapter is only a 10/100 (fast ethernet) adapter then you may want to invest in a gigabit adapter if your computer supports adding a new or different network adapter.

According to the spec my PC is equipped with Gigabit Ethernet socket.

I’ll trawl around the settings to see if there is something I can change.

Again thanks for your help.

It may be an issue with autonegotiation of link speed.

There are known issues with autonegotiation of any link at all with some routers (AT&T supplied ones, in particular). The solution there might also apply to you: insert a gigabit switch between router and MyCloud.

I have a Gigabit switch and have connected the PC and the WD MC to it. There seems to be a small difference . but my copying speeds from PC local folder to WD MC still only goes to around 11MB/s. However, I’m not completely sure what I should achieve.


That is still low. Best guess is your computer is still stuck at the Fast Ethernet 100MB speed. If the computer network adapter really is Gigabit capable, check the network adapter’s property settings for the Speed/Duplex setting. Ensure that setting is at 1GB.

Also make sure to use a Cat5e or better cables between the My Cloud, the gigabit switch/router, and the computer.

Is the bottom led yellow on the back? If so it is connected at 100MB not 1GB.

Hi and thanks again.I have been into the network card settings and set it to 1GB duplex and the bottom LED on the WD is now green. I did this before I ran the latest test. But it does seem that my PC is stuck at 100mb.
I’m wondering if there is another Ethernet card configuration issue that’s preventing the faster speed.


Replaced all my Cat5e cables with Cat 6 and turned off QOS . Now I’m getting 1GB. Not sure if it’s a combination of both or one of them. So I’ll just experiment.

Thanks again

Looking back at your post I didn’t see what operating system you are using. Are you using Windows?

The below image is from my new Desktop PC, Windows 10 with all updates. After a right click on my wifi adapter I click on Status, then at the bottom left, a click on Properties brings up the WiFi properties and shows my Asus PCE-AC68 Network Adapter. The Wi-Fi 2 with the red X is what came built into the PC and is much slower.