Slow speed with My Book 3.0

I’ve bought a My Book 3.0 but I can’t get it to transfer with the speed it supposed too, it transfer with usb 2.0 speed. I really don’t know exactly what drivers I am supposed to install, I’ve tried some different things but nothing have been helping. I have usb 3.0 ports on my motherboard so I don’t have an usb 3.0 adapter…

I don’t know about USB 3.0 but on 2.0 this sometimes helps. Go into device manager right click on drive properties and in policies change to better performance.

I am having this same issue. I have put the card that came with My Book 3.0 into two different slots, updated the bios, updated the 3.0 drivers and tried the soulution here in this forum and nothing works. I have spent hours on the phone with 2nd level tech and they have nothing for me. This really **bleep** and I am disapointed. I am hoping I can find something here because I was really looking forward to having 3.0 speeds of up to 640MB/sec (5Gbits/sec) transfer rates. I know these are lab numbers but I am only getting 20-30MB/sec tranfer rates on both my 2.0 and 3.0 drives. I was hoping to at least see 300-350 MB/sec of transfer, not 22.

Please give me some other things to try.

My Motherboard is an Asus P6T, I am tesgin the transfer rates with a less tha one year old internal ASATA drive at 7,500 RMPM. It has been defraged and is done so on a weekly basis.

Here is what I am gettign on a USB 2.0 drive

USB_2.png

Here is what I am getting on the USB 3.0 Drive. Definately not what I was expecting.

USB_3.png

What drivers are meant to be installed? I don’t use a usb 3.0 controller card.

The drive came with a board to put inside the computer and a CD taht had drivers on it. The drivers on the CD were outdated so I wen to the WD site and got the latest driver and installed that. Still nothing.

I’ve tried searching a bit so this my take on it. I think part of the problem is if this isn’t a new USB 3.0 capable computer there a lot of things that can interfer with the speed. Some of it are basic hardware issues that essentially restrict the read speed. It can’t write faster that it reads. Things like HD speed, ram, motherboard, Overclocking  all seems to be quite common bottlenecks on pre USB 3.0 computers. If you’ve got say a 5400 rpm internal drive an older motherboard and 2 gig ram and a lot of USB devices you are problably going to wind up with slow USB 3.0 speed.I think I also saw that the USB 3.0 card uses from 2-6 busses depending what hadware is there to start with.

Joe

The mothyerboar up date from ASUS was supose to correct all of this. From my understanding anyways.

random theories

  1. how large are your files? ive found that if i have 1000 small files, i cant get high speed due to it start/stopping between files, while if you transfer 1 1gb file, it starts slow, then gets faster over time. i understand that you should have much faster perfromance over 3.0 over 2.0, but its just a consideration

  2. create a new profile and see if that makes any difference (stranger things have happened use ot random settings that crop-up in a windows (or mac, or linux for that matter) over time.

  3. try burning a recent linux iso (ubuntu, fedora) and boot to it, they are “live CD” so you can run basic gui and get read/write access to drives. the most recent (ubuntu 10.10, fedora 14^note1) should have support for usb 3.0

note1: fedora 14 has usb 3.0 disbled by default, you will might need a kernel line for the boot to enable it

see http://fedoraproject.org/wiki/Common_F14_bugs#USB_3.0_ports_not_working

I am really not interested and having o go to all this trouble. When i purchase a new product that claimes to be up to 10 times faster I expect to see some sigificant preformance over the model it is replaceing. If I have to perform all kind of tests to see the value, then there is no value.

It’s only faster if all of the pieces are up to the task. How fast is your system HD 5400 or 7200 rpm? How much ram? There are a lot of things to look at with USB 3.0 given it’s newer that a lot of PCs trying to run it.

Joe

I certainly appreciate everyones posting her ein an effor t to help with this issue. As I mentioned before, I spent hours on teh phone with WD tech support and if they dont have an answer for me then I am pretty much sure that I may not find one.  I will not post a “Accept as solution” since I hav enot found one .

My computer is only a year old, 6Gig Ram, Intel i7 processor and is plenty fast for USB 3.0. All drives are 7,500 RPM. The My Book 3.0 came with the board to make the computer compatible with 3.0. I even updated the motherboard BIOS. Notsure what else I can do and neither did the WD people.  I am sure a moderator can close the thread if they wish.

I just saw this post http://community.wdc.com/t5/My-Passport-for-PC/Can-t-get-my-passport-to-function-properly-on-usb-3-0/m-p/102978/highlight/false#M3380  post 13. It woulddn’t hurt to check the bios.

Joe

I have the same problem…to an extent.  This will likely clear any misunderstanding up with the USB 3.0 speed issues. First off, I think everyone knows the speed comparisions from USB 2.0, 3.0 eSATA, and SATA.  My testing was as follows:

eSATA (3.0Gbps) to USB 3.0 = ~ 35MB/sec transfer speed of a 4GB transfer

eSATA to USB 3.0

SATA (3Gbps) to USB 3.0 = ~ 75MB/sec transfer speed of same file

From internal SATA.JPG

4 SSD’s in raid 0 (~650MB/sec speeds read/write to itself) to USB 3.0 = up to 229MB/sec

From SSD.JPG

The issue…if you have installed in your computer any NON SATA 6Gbit/sec or RAID configured HDD you will not see any improvement to your transfer speeds.  Because you are transferring to/from a USB 3.0 device to a slower device you will only see the speed of that slower device.  In my case my USB 3.0 is my slower HDD from my SSD’s in raid 0 so my speed is maxed at the USB 3.0 settings.  I hope this makes some sense.  I suspect if you have two USB 3.0 HDD and you transfer between them your transfer speeds will improve.  Also, if you have an internal HDD using the new SATA 6Gbit/sec speed (aka SATA 3), your transfer speeds between your USB 3.0 and SATA 3 will be what is advertised from Western Digital.  

MY RIG:

HAF922 Case w/800 watt PSU

Gigabyte GA-X58-UD5

Intel i7 920 @ 4.0GHz with H50 watercooling

12GB triple channel memory

2-GTX460 running 3-23" HD monitors
4-64GB ADATA SSD’s in RAID 0

1 - 750GB HDD, 1 - 1.5TB eSATA HDD, 1 - 2.0TB USB 3.0 HDD