Slow saving WD MyCloud + Mac OS X Sierra

Dear all,

I hope you are doing well.

Everything always worked fine and I don’t recall any changes (apart maybe from an update from El Capitan to Sierra), but recently anything (Word, Excel, PowerPoint, .PDF) I am trying to save is either crashing the program or taking a very long time to save.

Excel in particular seems to be creating a temporary folder as for instance “Excel” and then I have a choice in-between “Wait” or “Quit” for which:

  • Wait leads to “Server Disconnected” and then asking again if I wan to save my file
  • Quit obviously quits the file and it does not save

It seems that the folder then disappear and when I reopen the file after a force quit, changes have been saved.

I really don’t understand and have done a full check of the drive via the dashboard, everything seems correct and up to date and copying data is fast and quick.

Any help would be greatly appreciated.

Thank you very much,


Hi Styblue

I had office 2011 for MAC on ELCAPITAN then I upgraded to Sierra. Everything is still working fine. if they crashes try reinstalling the applications.

I am assuming you are saving directly to the drive, correct? why? I am sure you have your own reasons. I installed wd sync and I save everything to mycloud sync folder and let the sync app take care of saving/syncing to mycloud drive. This way I always have a copy on my local drive.

Alternatively, I save to documents and I configured wdsync to auto sync that folder. works pretty well both ways.

Hi redjupiter,

Thank you for your answer.

It is a good idea, although my office suite does not crash outside of saving in WD My Cloud. I tried reinstalling anyway just in case, but unfortunately, it has not improved the saving process with My Cloud. It also is the case when saving a .pdf document via Preview, so I don’t think it’s linked to the office suite.

I do save directly yes, the reason for that is that I have more data on WD My Cloud than the drive on my Mac can handle (4 To vs 500 Go) via Finder/Shared and then by logging-in.

What’s frustrating is that it used to work perfectly and the issues started fairly recently, I believe when I updated to Sierra, but not entirely sure this is the issue.

Any further ideas?

Thank you very much.


in the Windows world this problem is frequent with Microsoft office and the most causes were anti-virus, networking issues with mapped drives or broken mapped drives etc. Hard to tell, as you say it happens in other applications. Hard to tell, I would try disconnecting the drive (the mapping in OSX) and reconnecting it again and test again.

Thanks for your answer redjupiter.

I just tried to uncap/remap the WD My Cloud to Finder and unfortunately I still have the same issue.

I’ll keep searching!

Thanks a lot for your time.

I am having this exact same issue as well after upgrading to Sierra. styblue, did you ever find a resolution? We use My Cloud to share files in our office so being able to save directly to the My Cloud is important.

I’ve had the same issue ever since I had my WD My Cloud EX2. Any time I open a Word or Excel document on the NAS and save it there is about a 10+ second wait before it finishes saving. It creates a temporary folder called something like “” and writes data to that… I’ve done research but haven’t found anything. My network is all gigabit ethernet wired connection and my computer is only about 5 feet from the drive. Any other suggestions would be great! Thanks.