Slow Network Transfer Speeds


I’ve searched and read every post I can find regarding this problem and tried everything suggested. Here is my situation:

I have three WD NAS drives:

  1. WD My Cloud 2TB
  2. WD My Book Live 2TB
  3. WD My Cloud 4TB

All three drives are connected to the same brand new gigabit switch.
All three drives are connected to the switch with brand new Cat 7 patch cables.
All three drives show green lights on the network jack indicating a GB connection.
All three drives sit right next to each other.

I have tried switching cables, switching ports, rebooting everything, etc. I have verified that all three drives have the most current firmware

I tested all three drives with LAN Speed Test using a 20MB file from a computer connected to the same switch with a Cat 7 cable (it doesn’t even have a wireless card) and here are the results:
Drive 1: Read 506 Mbps Write 170 Mbps
Drive 2: Read 344 Mbps Write 186 Mbps
Drive 3: Read 92 Mbps Write 80 Mbps

These results are repeatable. I have tried writing/reading to different directories, no change. I’ve tried different size files, same relative performance results.

The sad thing is that the two drives that are performing as they should are refurbished drives, the 4TB is not.

Any help would be appreciated.

Which gen is the 4TB?

I’m sorry, I don’t see that anywhere. The model number on the bottom is WDBCTL0020HWT-00. Does that help?

I’ve never been able to get more then 100Mbps transferring to/from my My Cloud. Pretty jealous of your 2TB speeds. My only difference is that I have cat 5e, but obviously still gigabit capable. I’ve looked around previously for an answer to this as well and the only things I’ve ever been able to find is “that’s just how it is” or, “WD makes trash NAS solutions”.

I’m curious to see if anyone posts an actual solution for you.

Which firmware does it have? 2.x or 4.x? I don’t have any experience with Gen 2, but on my 3TB Gen 1, I get 100MB/s read and 90MB/s writes. I managed this by disabling everything but Samba.

Generally the “-00” denotes the first generation v4.x My Cloud. You can confirm by accessing the My Cloud Dashboard and the firmware is listed on the main home page of the Dashboard.


So I bought new 4 ft long power strips for my rack and as part of installing them I rearranged everything. Which means I shut everything down and disconnected everything.

Now it is working just fine. Very high transport speeds. My guess is that from the time that I bought the new switch and cables I never actually powered down those drives.