Sleep timer configuration not working on newer My Passports


I can’t seem to be able to configure the sleep timer on my newest My Passport, WDBABM0010BBK

I have tried raising the timeout, I have even tried setting both the OS preferences AND the SmartWare preferences to NEVER put the hard disk to sleep, but it still spins down after 5 to 15 seconds from the last access. This is seriously affecting the performance of many tasks, for example watching a movie from the disk.

I have tried this disk on other computers and it has the same problem. I have owned My Passports for a long time and I have never had such issues with the previous models, for example WDBAAA5000ARD

I understand the need for power saving and everything, but seriously, this is a bug. 15 seconds is way too short a timeout for many uses and the option to raise it is not working.

I’m not the only user experiencing this issue, see this unresolved post.

Hi there,

The hard drive should not spin down after 15 seconds (That’s not normal). Below, I’ve outlined some steps that you may want to try: 

Update the drive’s firmware. See the link below for more info:

Note: Make sure that all your data is backed up somewhere else prior updating the drive’s firmware. 

Test your drive with Disk Utility: 

Make sure your Mac computer has the latest updates installed.

Hope it helps :slight_smile:

Thank you for your advice, but I had already done all that.

The drive has the latest firmware, Disk Utility can’t find any problem, and the computer has the latest updates.

The drive spins down after 10 to 15 seconds, on every coputer I’ve tried it on.

As I mentioned above, I’m not the only one having this issues with the newer drives.