Sleep and access issue MBL

The MyBook Live (recently purchased) has eventually settled down (see previous posts for info).

I have however now encountered another issue i.e. the drive which was previously going to sleep as per expectations is now staying awake with the green light flashing all the time as though it’s being accessed?

This has only started since we purchased a brand new Windows 7 Laptop.  The Laptop is on the home network, I can see my Mac the MBL and Twonky Services.  I can access my media through Twonky and through MBL Public Shares on the Lappy.  I have turned off Twonky merely as a process of elimination – still flashing green.

Another issue – when I tried to access the private share on the MBL I was prompted for username and password.  I put in the email address and password I use to access WD2GO web access.  However this didn’t work so I tried the password I use to access the drive’s account plus email address – again nothing.  This has got me puzzled.  Do I need to set up another account as I’m trying to access on my local network from another PC which is set up in the wife’s name, or is there another reason why I can’t access this private share?  The Laptop is set up for sharing BTW.


If your MBL goes to sleep within 30 minutes of shutting down Windows 7 boxes, then I think I know what the issue is:

My Windows 7 box logs into any public shares automatically after it “discovers” Samba shares.

My QNAP used to be awakened every 30 minutes by Windows 7 desktop.

   I put in the email address and password I use to access WD2GO web access.  

That’s not the same, unless you are actually using WD 2go to do that.  If you’re just using normal windows mapped drives, then you should use the User ID and password you defined in the SHARE setup, not the WD 2go setup.

Email addresses have nothing to do with it.

1 Like

Thanks for the prompt response. MML won’t currently sleep even with the Lappy completely shut down plus the Mac? I’ve noticed the adsl LED on the router flashing furiously even with all but my iPad shut down. Re: access to mapped drive, ah, I hadn’t used the right username. I’ll do a bit more investigation with the sleep issue. I’ve also noticed my TM backups are running slow too. I have tried a reboot but it hasn’t helped.

Right, MBL has finally entered sleep state.  The only thing I hadn’t tried was shutting down my iPad.  Within twenty minutes of shutting down the iPad MBL went to sleep :smileyvery-happy:  Now I’ve got to find the reason why my iPad has been stopping MBL from sleeping (if it was solely the iPad)?  As far as I’m aware the only link to MBL are the two apps which come with this unit and which I have installed on the iPad.  I did think they were inactive once you let the iPad sleep but perhaps I’m mistaken?

After a number of false trails looking for why my MBL keeps having sleep issues I think I’ve finally got to the bottom of why this is happening, though no sure about the solution.  Firstly the iPad does seem to cause a few sleep issues but I’m confident now that this is a minor player.  If anyone is using a Mac they may wish to take note.  I have had a number of instances whereby the WD Quickview icon will not expand when clicked, hence no access to Dashboard.  Each time this has happened it has coincided with MBL not entering sleep state plus the green light flashes quite regularly as though there’s a lot of disk activity. The only option I’ve been able to find when the Quickview icon won’t expand is to reboot the Mac.  As soon as the Mac is rebooted the Quickview icon opens so I can enter Dashboard (if I wish too) and minutes later the MBL enters sleep state.  Four times I’ve noticed this issue and four times a reboot has cured both problems.

Now what I don’t know is why this is happening.  As I have Quickview installed in my W7 VM I’m minded to install this software from the Mac and see what happens.  I can after all still access Dashboard from the VM. 

The last line from my previous post should have read UN-INSTALL on the Mac.