Shutdown of My Cloud FW 2.30.181 using SSH

After buying a single bay WD MyCloud just a couple weeks ago I realized there is no way to make a clean shutdown (no command in WD apps, nor any HW power switch).

Following suggestions I found in older posts in this community I figured out that the following command actually WORKS on My Cloud:
$$ ssh sshd@My Cloud IP address halt -p
(this implies the SSH feature to be enabled in My Cloud settings, and an appropriate password provided)

My questions are:

  1. should I expect anything wrong to happen in using this shutdown command (“halt” in ssh) ?
  2. if nothing wrong, why not make it available in the SW interface ?
  3. if this is instead deprecated, what should I use ?

Thanks Piero

WD has never indicated to it’s customers (us) why they chose to remove the shutdown option in the second gen v2.x single bay My Cloud firmware. The lack of a shutdown in the second gen v2.x My Cloud dashboard has long been complained about in this subforum with many past discussions about it. The following WD Knowledgebase article explains the official methods of shutting down a single bay My Cloud device including using the WD Access program for those with the second gen v2.x single bay My Cloud units:

One can download the software for the single bay My Cloud at this link:

Thanks Bennor.
The problem with your suggestions however is that not only the dashboard, but also all other tools (WD Access, for example - WD Quick View doesn’t seem to load on Mac) do NOT show the Shutdown command either. Not providing Shutdown for FW 2.xx seems a well known and deliberate choice; and BTW in the link you suggested How to shut down a My Cloud Device, it is clearly stated: “Single-bay My Cloud with firmware only have Restart and Log Out” (shutdown/hybernate is missing).

That’s why I asked why.
I used ssh to activate the halt command (I got this suggestion from an older thread in this forum), and it worked as I expected Shutdown to work, at least in the few cases I tested.

However being the removal of Shutdown from FW 2.xx a deliberate WD choice, the only thing I could think of is a known bug that is not yet fixed…

Another question: I understand FW 2,xx is a more recent version of FW 4.xx. Is it correct ?
If so this would be another curious choice…

Thanks anyway for you help

WD has chosen not to tell we end users (those of us in this subforum) why they decided to remove the Shutdown option from the newer second generation single bay My Cloud units. Nor has WD indicated why they decided to confuse we end users by using 2.x for their newer single bay My Cloud devices versus using 4.x for the older single bay My Cloud models. We are end users such as yourself not WD support employees. We can only guess, speculate and shake our heads as to the confusing decisions by WD with their products and software.

Users who are using the second gen v2.x single bay My Cloud units are supposed to use WD Access to shut down the device. If the WD Access program isn’t seeing the My Cloud on the local network one should look into that particular issue to see if there is something specific on that computer (like firewall/security software or network settings) that may be affecting the program’s ability to access/see the My Cloud on the local network. The typical troubleshooting step of uninstall the WD Access program, then reinstall it is usually a good first step.

I assume that WD knows full well about the many complaints about the missing shutdown option even though the User Manual for the second gen v2.x single bay My Cloud units mentions the shutdown option in the Dashboard. Requests were made in the My Cloud Ideas subforum forum years ago to fix this lack of shutdown, but WD has chosen not to do so in all subsequent firmware releases for the v2.x single bay My Cloud models. As such I assume WD will never fix this particular issue no matter how many complain about it.

There is also a web browser trick/hack that one can use within the My Cloud Dashboard to “unhide” the Shutdown option that some use or some simply use the web browser to issue the shutdown command while the Dashboard is loaded.

@PieroF If using Windows 10 and having WD Quick View you can perform the Shutdown using that. See example image below. I have had my second generation My Cloud (WDMyCloudTwo) for about a week.


The version 4.xx firmware is a Debian Linux with 64k pages. This means you can not apt-get packages from the standard Debian sites.
he 2.xx firmware uses busybox. Busybox is a compact special Linux. You will find busybox in almost every smart device. It also uses 64k pages. So don’t use atp-get.

Thanks all for your answers.
Bennor: I read your very useful contribution in a thread of couple years ago about this topic. And I found the suggestion about ssh in that thread.
cat0w: WD Access and WD Quick View on my Mac are of no help to me; as you can see in the images their menus do not include shutdown/hybernate (“Spegni”, in Italian).
rac8006: thanks for the explanation.

In addition I successfully tried the javascript solution; I think of it as an alternative to the terminal ssh I already used.
I’m also curious to try the script solution, but I still have to learn more about.

I’m new to this community and I found it very helpful and responsive!!
Thanks again!




I don’t bother with the javascript shutdown option. I simply use Putty and have a batch (.BAT) script setup with a short cut to it on my Windows 10 Desktop. To shut down my first gen My Cloud I simply run the shortcut to the batch file and the My Cloud shuts down. I also use an SSH app on my mobile devices and can shut down the My Cloud using that app if I don’t have access to a PC. The SSH commands to shut down the two My Cloud models are slightly different.

For a first gen v4.x single bay My Cloud the command to shut down the unit is:

plink.exe -ssh -l root -pw [password] [ip address] /sbin/shutdown -h -P now

For the second gen v2.x single bay My Cloud the command is probably something like this:

plink -ssh -l [name] -pw [password] [ip address] halt -p

Plink is part of Putty which can be downloaded from this link:

On my mobile device (Android) i use SSH Button:
One can modify the commands (without the “plink.exe” value) within the SSH Button app to issue the shutdown command via their mobile Android device.

I’m using a MacOS X on my network and I find very easy to use its built-in Terminal:
$$ ssh sshd@[IP address] halt -p
I’m asked for connection confirmation and then for ssh password, and it’s done.

Previously I had enabled ssh in the MyCloud Settings/Network Services, providing my password.
I think I’ll stick with it.

Thank you!
I enabled SSH on the WDMy cloud and I set up a password
Then I went to the Terminal and I entered $$ ssh sshd@[IP address of mycloud] halt -p
It doesn’t work with $$, so I used without it.
Then this message appears:

The authenticity of host ‘IP address (IP address)’ can’t be established.
RSA key fingerprint is SHA256:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.
Are you sure you want to continue connecting (yes/no/[fingerprint])?

Should go for yes?

Yes. Generally the first time you access a device via SSH you will be asked to accept the device’s security certificate.

You are the Star Bennor!
Everything is working!
You make my Day! :pray:
Thanks a lot for your support!
Best Regards!