ShareSpace 2TB to Join SBS 2008 Domian


We are having 2TB Sharespace, we are having trouble connecting it into our SBS 2008 Std. Ed. Domain environment. Everytime we provide Domain Name, Domain Netbios Name, Domain IP, Domain Network Admin User Name & Password we get “NET_ERROR: Join ADS Failed”.

We are having following configuration:

  1. Reserved IP Address of the range “192.168.1.x” being provided by DHCP Server.

  2. Default Gateway & DNS Server entries for the Sharespace set = Domain Controller IP Address.

We tried with both, giving full domain controller netbios name as well as just the server name, but in both cases the same error is generated.

In case we change Administrator User Name or Password we get “KINIT_ERROR: Preauthentication Failed”. And the fact that sharespace is geting IP Setting (Already Reserved in DHCP for Sharespace) Dynamically from the DHCP Server means the Sharespace is very much communicating with Domain Controller, but it is not able to join the domain.

And as far as the fact that user trying to join the sharespace to Domian Controller should be a member of Domain Controller/Users is also being met. Because the user is the “Network Admin of the domain” which in SBS 2008 environment lies at = domaincontroller/Mybusiness/Users/SBSUsers/ but this “Domain Network Admin” is actually the member of all the built-in groups (and also of domaincontroller/Users), so it should not be the problem area (Just for information). We even tried creating a user at default location, but that also didn’t solved our problem.

Can anybody help us out?

We would be very thankful.


We are having an identical problem with a 4TB Sharespace, joining to SBS 2008 as well.  When we contacted WD, they told us they would not provide tech support if the Active Directory was over 32 users, so we’ve been left out in the cold.  We were reassured on several occassions that this was possible and supported, but have yet to receive any help.  Just a heads-up.


Spent 30 minutes with WD’s wonderful tech support today… Paid $15 for them to tell me that it is NOT compatible with 2008, even though other agents had told me it is.  I think we’re giving up and throwing it on a 2003 server instead to relieve some of the headache, but if you get it to work, let us know!  Good luck!


I am also having the same problem.  All the other devices on my network can see the MyBookWorld except the SBS 2008 server.  I also have a Server 2008 as my SQL server and this can see the MyBookWorld just fine.  The SBS 2008 even handed out a DHCP address to the MyBookWorld but I can not browse the device.  Not sure why SBS 2008 can not see the MyBookWorld but the Server 2008 can.


Just unpacked our 4TB ShareSpace and installed it. Initially impressed, it has a simple interface, sensible initial config.

We configured a static IP address, set the time, and then finally tried to put it onto our 2003 domain.

Entered domain, net bios name, IP and admin credentials.

Failed to join domain! [KINIT_ERROR: ‘Preauthentication failed’]

We have <32 users in our AD. The 2003 server is a vanilla config.

It’s a real pain when things like this don’t ‘just work’.

This may be a silly answer, but ensure that you are including the entire domain name… For example: “server01.local” rather than just “server1”. Also, the admin username/password is an administrative account on the domain, rather than the username/password for the Share Space. The preauthentication error is only the first of many of your future problems, I’m afraid :wink:

1 Like

I have tried this, but on 3/3 occasions the thing just locked up and had to be rebooted. Nothing in the log either.

It must be going down a different code path though because it only does it for what you’d consider to be a fully qualified domain name, trying deliberately non-existent domain names did not cause a lock up.

entering MYDOMAIN, result PreAuth error

entering MYDOMAIN.local, result freeze

entering RANDOMDOMAIN, result ‘failed to join domain’ (reasonably enough)

entering RANDOMDOMAIN.local, result ‘failed to join domain’ (so not some freaky bug related to adding .local)

How important is the netbios name entry? I typically leave that blank.

Not happy. 4Tb of unusable brick in my office. We have an Acer Altos as well that ‘just worked’ with our AD. So I know it can be done…

MBorland - did you get yours working in the end? Your post sounds rather ominous… :slight_smile:


i have the same problem but on a bigger corporate network with windows 2008 enterprise server. I filled out the whole domain name and the ip of the domain controller, the right username and password. I created also object computer on the AD with the name of the wd sharespace, but this doesn’t work. It freezes. Does anyone have a proper connection to an AD???


I tried to hook up a 4TB ShareSpace to a Windows Server 2008 Standard domain and got back a could not join domain. After spending hours researching this as well as on the phone with WD. I found out that they only support Server 2003. Even after knowing this and pouring through their documentation I found nothing, but one line (mind you it was even in parenthesis) that stated that the product would only work with Server 2003. Hope this helps everyone.


Not sure if this will help, but I got my WDShareSpace 4Tb brick to join my domain, three times.

So, let me explain.

The first time around it joined miraculously. I have no idea what I did right (or wrong?)  0_o

But I had a problem, I couldn’t see any of the users from my domain AD and I couldn’t access the shared space using an AD user. I figured I did something wrong since this is supposed to have some sort of way to use AD and Users and Folders… I was so lost.

I removed the WDShareSpace from the domain and went back to a workgroup. I had some access, but not true AD access.

I decided today to rejoin to the domain and I was getting all of your same errors listed here. I tried everything I could think of, I must have been at this for over an hour, reading posts, trying things, thinking I had my domain and NetBios name reversed. Nothing worked. Then suddenly it worked!!!  It worked with a combination I had used before, so I don’t get it. I must have done something different, and I think/thought I knew what it was…

Here is what worked for me, now I must say at this point I am on SBS2003 with only 15 users, so I fall within the correct guidelines, but maybe this is what’s going on for the 2008 users.

I entered all of my data in the workgroup page to join my domain.

After I entered the password, I hit enter on my keyboard, as anyone would normally do and I got an error.

So then I used my mouse pointer, and without changing a thing, I clicked the Submit button.

Voila! it saved my changes, joined my domain, now I can create folders with my user’s names, and then add AD users to the shared folders.

So it had something to do with actually clicking on the submit button with a mouse pointer, not hitting enter.

I hope this helps someone, and I’d like the past couple hours of my life back please!!!


That happened to me as well, gave me the error of "KINIT_ERROR:
‘Preauthentication failed’. "
Eventually the issue was the administrator password
domain that had an alphanumeric character “%$&”  if you have any
unusual character or try to change the password to create another
administrator user with a simple password for example “aaaa.22222”

sorry for my bad english


I am also having the same problem on Windows 2008 x64 Russian edition.

Is problem solved or not?

to Moderator


(Microsoft Active Directory support   - Will join an Active Directory domain to utilize AD users and groups.)

IT’s lie!!!

P.S. Sorry for my bad English

Has anyone found a solution to this???

I have read through this entire post. I have tried everything everyone has suggested. We already had a backup 2003 DC. Using that did not work. I have tried every combo of domain, domain & netbios, domain.local and netbios. Even domain\administrator for the username. Nothing works.

This is a paperweight… Soo happy we purcahsed 2!

Any new developements would be appreciated.

I haven’t had a chance to go through the entire thread here, but I thought that I might add, in case nobody knows, Server 2008 is not supported on the present firmware of the WD Sharespace.  There is support for AD and Server 2003, however.  Now having said that, I checked with our product team, and it appears that support for Server 2008 is being added to the next firmware update.  I’ve also been told that the next firmware update should be available sometime later in May.  I hope this helps.

Can I get clarification on the 2008 vs 2003 Domain?  Is it the AD version or the Server version that matters? 

The AD has a 2003 and 2008 flavor.  Does the WDShareSpace currently work if the 2003 AD is running on a 2008 Server? 

WD system is Linux not Microsoft!!! MS server 2008 using NAP server for adding to AD. You have to configure MS server 2008  for adding to domain non MS OS system. In MS server 2003 is possible add all OS automaticly when you create domain. In MS server 2008 not! Server 2008 have different rule to join nonMS system then server 2003. I hope to help you.

“Server 2008 is not supported on the present firmware of the WD Sharespace.” is not true!!!

Thank you Charlie for this news.

Can you explain us how do that?

Hi !!!

I have the same problem with an 8 TB ShareSpace and Windows Server 2008 Standard x64 …

Any idea when releasing the new firmware compatible with 2008 AD??


Google helped me to find this link

There is a promise for a version 2.2.8 that will finally support Active Directory 2008.

I posted a question towards WD Support how to get this firmware as it is not offered with the built in update feature.

Let’s hope for the best!

Having purchases a WD sharespace I have to say what a big mistake it was.

In the past we have used cheaper less well known brands and have had no issues whatsoever. On purchasing the WD we realised that the Active Directory support for Windows 2008 was not there, coming to these forums to get some help and advice only to realise that there are a bunch of people in the same boat with no answers coming from WD.

What a joke of a product and even worse support and community response. Will definatly not be purchasing WD again.