Shares Size

I understood from a post on this forum that currently the share sizes cannot be set ( ). So they are somehow set automatic. But there has to be a way of knowing at least how large a share is. As I like to know how much money I have left in my pocket, I like to know the same thing about my space left on a drive. I’m a pretty meticulous person so this unclear sizing baffles me.

I set my drive on JBOD as I like having all space available without mirroring/backup. And i created 3 shares on one of the volumes. I tried copying a bulk of folders from my computer of ~65GB. On one of them it told me I need an additional 13GB and it cannot copy. On the other it worked. I’m puzzeled here. I seem to not have any control over their size.

What is the algorithm behind share sizing? There doesn’t seem to be a standard chunk of XGB given to a share as my copying worked on one share but failed on the other.

Is there still space on my drives that is “unallocated”? I need to make some more shares to have it available?

As you’re in JBOD mode, the drives are basically working independently, so if all of your shares are on one drive it is quite possible that one will be full (or almost full) whilst the other drive is totally empty. When you set the share up, you tell it which of the two drives you want that share to be on. Essentially the shares are just folders on the drive, and so they can grow until they fill it.

For how much space is left, the simplest way (at least on Windows) is to map a network drive to it (under the Tools menu in Windows Explorer). If you then select the root level of My Computer (the one labelled “Computer” in the left hand pane) you can see for each drive (including the mapped ones) how much space is free and how much total is available. But remember that as one share on a drive gets bigger, the available space for all shares on that drive will decrease (you should see the same available space and overall size listed for all shares on a given drive on the MCM).

Basically if I remember correctly the max share size is as big as the drive that it is on, although it is possible to set a maximum file size allocation for each user set up on the MCM (which isn’t quite the same, unless the only thing you have on the MCM are shares just for each user and nothing public or multi-user shared).

Thanks @DarrenHill

The thing is that I set up 3 identical shares on each of the 2 volumes. We are 2 people that want to use the WD. So I set up a share for 1, a share for 2 and a common share. On each volume. I couldn’t define any dimension. 

After all this setup I tried to copy some things - the bulk of files of ~65GB. And I got the “you need additional space” message. So all the volumes were clean. I even looked up on the home dashboard and it was all clean. Nothing on the drives. So why no space left? It’s like that specific share got an allocation of ~50GB.

All I can think of is that user quotas were set up when you set the users up on the MCM. Can you check that and see?

See pages 42-43 in  the manual for details. That’s the only restriction that I know of for file space usage on the MCM (aside from the obvious disk size limit of course).

If not that then I’m out of ideas, and your next step may be to raise a ticket and take it up with WD support, unless anyone else here has additional thoughts.

thanks DarrenHill. I mapped the folders in Windows Explorer and now i use them as “regular” partitions. So i access them from there. And my limitation problem doesn’t seem to appear anylonger. I will get a screenshot or something it i encounter it again.