Shares not displaying in the GUI on MyBook Live 3TB

After the Firmware version: 02.41.05-034 update failed in the GUI, I manually ran it via SSH and it finished successfully and rebooted.

Upon reboot, the user I had created no longer exists, and the shares don’t show up in the UI, but I can still browse them via the UNC path and all of the data is there.

When I try to re-create the existing share name, it gives error “33152 - Failed to create the specified share. Please try again.”

Please help.

Try this guide

It should reset the dashboard stuff back to defaults and allow you to create your shares in the dashboard again

Thanks for the suggestion, however when I followed the instructions, it reset the interface, and the shares disappeared.  When I tried to re-create the main share that I had on there previously which was called ‘Backup’, it now gives me an error saying that ‘Backup’ is a reserved name, and I can’t re-create it, so now I can no longer access the 1.5TB of data that is there. 

See next post


We should be able to fix that specific problem… Gimme a sec

In PuTTY or Terminal, issue the following command

nano /etc/samba/overall_share

 Copy this text and then go to the PuTTY or Terminal window and scroll down to the bottom and right click your mouse button to paste this text

  path = /shares/Backup
  comment =
  public = yes
  browseable = yes
  writable = yes
  guest ok = yes
  map read only = no
## END ##

Hit control and o

Hit enter

Hit Control and x

This will save the edited file

The Backup share should now be browseable on your network again

What you ultimately need to do is rename that share because Backup is indeed a reserved share name in the firmware. You may have added the share on an older firmware prior to this restriction.

Run this command in PuTTY or Terminal… It will rename the share from Backup TO Backups

mv /shares/Backup /shares/Backups

 Then add a share called Backups in the dashboard

And you should be all fixed up :slight_smile:

Thanks alot, that has solved the problem!

I do have another unrelated problem that I will start a new post for though.  Maybe you can help with that as well.

I’ll give it my best shot. If I don’t know the answer, I’m sure someone will