Share WDTV on my network

Hello all,

I just got the WDTV Live Plus and have everything almost setup like I want.

I have a wireless USB that gives me access to the internet from my wireless router in the other room.  I can play youtube videos or netflix and everything seems to work fine.

I have a 2 TB USB hard drive plugged into the other USB port on the WDTV and I am able to play my music or watch movies.

The last thing I want to do is connect to the USB drive that is connected to the WDTV from my main computer.  I don’t want to connect to my PC from the WDTV so even though I have file sharing turned on I don’t have any folders shared.

Accoriding to the user manual all you need to do is make sure the WDTV and the PC are on the same network, make sure Share WDTV on my network is set to ON, and run the discovery tool.  The two devices (PC and WDTV) are on the same network.  PC is 192.168.1.2 and WDTV is 192.168.1.6.  I can see the WDTV from the router but everytime I try to connect it fails.  I have tried the DNS name of WDTVLIVEPLUS like \WDTVLIVEPLUS\ and that fails as well as using the IP address.  I tried adding the name of the USB drive like \192.168.1.6\USB2 but that fails as well.  I downloaded NETSCAN and again I can see the device in the list but it won’t let me open it.

Any suggestions?

Thanks

Chris

I have never installed or used the WD discovery tool so I am not sure if this applies in your case, but I have seen mentioned in other threads to make sure that the workgroup name in your computer matches the workgroup name that is stored in the WD. You can go into the WD Network setup and enter the same workgroup name that your computer has.

Thanks for the suggestion Scandy but they are both the same.

I did discover that it is a PC problem and not the WDTV live problem.  My wife has a laptop and I checked her computer to see if the WDTV would show up there and sure enough it does!  I can browse the USB drive and everything works great.  I checked her network settings versus mine and changed mine to be just like hers but still nothing.  The only difference is that hers is wirelessly connected to the network and I am wired.

At worst I can use her laptop to push files to the device but I would rather be able to do it from both PC’s.

Any other suggestions?

Chris

Found it!

It turns out that I am using Zonealarm and my home network was not in the trusted zone.

In Zonealarm under FIrewall -> Zones I added the IP range 192.168.1.2 - 192.168.1.255 to the TRUSTED zone and refreshed my network and there it was.  I am able to browse and everything works great.