Setup WD My Cloud (on mac, el capitan)


I have some problems setting up my WD MyCloud. After connecting it to my router the light turned blue, it seemed to work. Installed it, made a account. And I could acces it via Which seems like not the best solution… After watching some video’s from WD I found the setup link. Downloaded it and tried to install this setup but the setup software just would find my MyCloud:

So I just installed the WD My Cloud app on its own, works just fine. But I rather use the MyCloud trough my finder. But I when I try to connect I get an error: The ip adres is incorrect or it might nog be installed. So back to… And suddenly that site didn’t work anymore. So I wanted to check if everything was oke with my MyCloud an I read that I should check http://mycloud.local/. But that doesnt work either.

I also tried to connect trough my finder… as i guest I can see all the maps but they are empty and when I try to connect as a user it says there is a problem with the server. Check the ip-adres and try again…

so… all the errors I get:

I tried everything, but it just doest work… And it also does’t work when I go to my ip adres. So my feeling is my mac doest find the MyCloud(?).

The main issue is: how do I get the MyCloud to work via my finder? So I don’t have to use that awful app… :’)
But I thought the extra information might trigger something with some of you guys. Hope someone can help… i’ve been struggling for days… Thanks

Please note that there is a problem with El Capitan and the My Cloud. There is much discussion with some possible workarounds to issues discussed in the following thread.