Setup an EX2 on a network without auto DHCP


I have a WD MyCloud EX2, and I managed to set up everything smoothly at my home (network, SSH access, applications, web access with port forwarding, etc.).

Now I brought the equipment to the office, but I can not access it at all. I’ve done a reset, and nothing.

The difference is that, at home, I’ve connected the WD directly to the router and have DHCP enabled on router, so I could immediately access to the dashboard.

In the office the network is somewhat more complex. I can not connect the WD directly to the router, and DHCP is disabled. I’ve tried with mcp2_windows_setup.exe and accessing the dashboard by the browser, but it can not find the WD… As I said, I already have done a reset and still does not find it.

How can I set up my EX2 in this network environment? I think if I could access it to configure the network manually, it would work, but without accessing the dashboard, it is impossible…

Thank you very much!

Best regards,

Hi there,

Have you tried setting up, a static IP by connecting the drive directly to a computer and then connecting the unit to the router ?

I suppose an immediate question is, are you authorised to attach the EX2 to your office network? If your office network is set up in some strange way to prevent unauthorised devices being connected, there is probably a good reason for that.

Any chance of providing a bit more background on your office network? An office with no DHCP sounds very strange. You may not be able to plug the EX2 directly into the router, but that probably makes no difference as you will probably be connecting it to a switch elsewhere which is connected to the router and/or other DHCP server.

Are you sure the network point you are plugging the EX2 into at the office is actually “patched in” to the network?

How is TCP/IP configured on your PC at work? DHCP or otherwise?

Hi ArMak and George,
Thank you for your reply!

In fact I could already connect. The problem was that, even with the reset, the network settings that I had configured at home, remained, so it was not working. I tested again at home and I checked it.

So, I configured the static network settings at home, according to what was defined in the office, and it worked! I can access everything (dashboard, ssh, https, ftp, etc.) within the network. From outside the network, I can access with the Android app, I can access the dashboard, but I can not access via ssh. I think it has to do with the network Firewall settings, which is blocking the access by ssh, because within the network it works well, and from outside, ssh does not, despite the port forwarding is configured.

Anyway, thank you very much for your answers!

Best regards!

I’m glad you’ve got it working.

No surprises that incomming SSH is being blocked by your firewall. As we’re talking about an office network I think you would need a damned good reason to not have it blocked, and merely “playing” with the EX2 remotely doesn’t even come close.

Is this an office you own/manage, or do you just work there?